summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortydell2015-06-12 15:12:03 +0200
committertydell2015-06-12 15:12:03 +0200
commit702042316d6d70738ef8c9c71a4a6592a5abe02a (patch)
tree094f6572abdbc499383cbc80d3529d8df727f273
downloadaur-702042316d6d70738ef8c9c71a4a6592a5abe02a.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD52
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..872fa580fe5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libappstore-bzr
+ pkgdesc = Provides access to the Ubuntu app store through PackageKit
+ pkgver = 22
+ pkgrel = 1
+ url = http://launchpad.net/libappstore
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ depends = packagekit
+ depends = sqlheavy
+ depends = libgee
+ depends = gtk3
+ conflicts = libappstore
+ replaces = libappstore
+
+pkgname = libappstore-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66cb9affc4fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Contributor: Jameson Pugh <imntreal@gmail.com>
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=libappstore-bzr
+pkgver=22
+pkgrel=1
+pkgdesc="Provides access to the Ubuntu app store through PackageKit"
+arch=('i686' 'x86_64')
+url=http://launchpad.net/libappstore
+license=('GPL' 'LGPL')
+depends=('packagekit' 'sqlheavy' 'libgee' 'gtk3')
+makedeps=('cmake')
+conflicts=('libappstore')
+replaces=('libappstore')
+
+_bzrtrunk=lp:libappstore
+_bzrmod=libappstore
+
+build() {
+ cd "$srcdir"
+
+ if [ -d ${_bzrmod} ]; then
+ bzr up ${_bzrmod}
+ msg "The local files are updated."
+ else
+ bzr co ${_bzrtrunk} ${_bzrmod}
+ fi
+ msg "Bazaar checkout done or server timeout"
+ msg "Starting make..."
+ if [[ -d ${srcdir}/build ]]; then
+ msg "Cleaning the previous build directory..."
+ rm -rf ${srcdir}/build
+ fi
+ bzr clone ${srcdir}/${_bzrmod} ${srcdir}/build
+ cd ${srcdir}/build
+
+ [[ -d build ]] || mkdir build
+ cd build
+
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+}
+
+package() {
+ cd "$srcdir/build/build"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: