summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2019-09-16 15:25:07 +0200
committerDan Johansen2019-09-16 15:25:07 +0200
commitb975a2e1a20e92db50168c6823109480b0592039 (patch)
treef785e87bcc474f982194454e85e4d193b76f51e3
downloadaur-b975a2e1a20e92db50168c6823109480b0592039.tar.gz
initial commit, version 2.7
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eaec585a2e24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libarchive-qt
+ pkgdesc = A Qt based archiving solution with libarchive backend.
+ pkgver = 1.0.2
+ pkgrel = 2
+ url = https://gitlab.com/marcusbritanicus/libarchive-qt
+ arch = x86_64
+ arch = aarch64
+ groups = coreapps
+ license = LGPL-3.0
+ depends = libarchive
+ depends = qt5-base
+ depends = zlib
+ depends = bzip2
+ depends = xz
+ source = https://gitlab.com/marcusbritanicus/libarchive-qt/-/archive/v1.0.2/libarchive-qt-v1.0.2.tar.gz
+ md5sums = f8bfc8db69ae2fe7dd1f689e71178235
+
+pkgname = libarchive-qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82c9289a9df2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Marcus Britanicus
+# Contributor: Dan Johansen <strit@manjaro.org>
+
+pkgname=libarchive-qt
+pkgver=1.0.2
+pkgrel=2
+pkgdesc="A Qt based archiving solution with libarchive backend."
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/marcusbritanicus/$pkgname"
+license=('LGPL-3.0')
+depends=('libarchive' 'qt5-base' 'zlib' 'bzip2' 'xz')
+groups=('coreapps')
+source=("https://gitlab.com/marcusbritanicus/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+md5sums=('f8bfc8db69ae2fe7dd1f689e71178235')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd ${pkgname}-v${pkgver}
+
+ qmake-qt5
+ make
+}
+
+package() {
+ cd ${pkgname}-v${pkgver}
+ make INSTALL_ROOT=${pkgdir} install
+}