summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-01-24 23:27:10 +0530
committerlibrewish2020-01-24 23:27:10 +0530
commitbfa53dbe1639be28df83125a9d092f66dce16441 (patch)
tree230abedfd535c29dba10c0d4927213bd2ce22a25
downloadaur-bfa53dbe1639be28df83125a9d092f66dce16441.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60fe4ac28668
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libarchive-qt-git
+ pkgdesc = A Qt based archiving solution with libarchive backend.
+ pkgver = v1.1.1.r0.b653d20
+ pkgrel = 1
+ url = https://gitlab.com/marcusbritanicus/libarchive-qt
+ arch = i686
+ arch = x86_64
+ groups = coreapps-git
+ license = LGPL-3.0
+ makedepends = git
+ depends = libarchive
+ depends = qt5-base
+ depends = zlib
+ depends = bzip2
+ depends = xz
+ provides = libarchive-qt
+ conflicts = libarchive-qt
+ source = git+https://gitlab.com/marcusbritanicus/libarchive-qt.git
+ md5sums = SKIP
+
+pkgname = libarchive-qt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f30c76ce0f75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=libarchive-qt
+pkgname=${_pkgname}-git
+pkgver=v1.1.1.r0.b653d20
+pkgrel=1
+pkgdesc="A Qt based archiving solution with libarchive backend."
+arch=('i686' 'x86_64')
+url="https://gitlab.com/marcusbritanicus/libarchive-qt"
+license=('LGPL-3.0')
+depends=('libarchive' 'qt5-base' 'zlib' 'bzip2' 'xz')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('coreapps-git')
+source=("git+https://gitlab.com/marcusbritanicus/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}