summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryhfudev2015-08-30 09:49:22 -0400
committeryhfudev2015-08-30 09:49:22 -0400
commitbe8f436db77ee349ac13af02b358b09fa01e71a3 (patch)
tree759be20b388d90a5b2dbeb22003262e0d671f6aa
parent46391367e3ea5405374c9d1094551972499c3851 (diff)
downloadaur-be8f436db77ee349ac13af02b358b09fa01e71a3.tar.gz
update to libarcus 15.06.03
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD44
2 files changed, 38 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe1327c89cfb..1e9b14dec871 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = libarcus
pkgdesc = A library designed to facilitate the communication between Cura and its backend and similar code.
- pkgver = 424ae4f
+ pkgver = 15.06.03
pkgrel = 1
url = https://github.com/Ultimaker/libArcus
arch = i686
arch = x86_64
+ arch = arm
license = GPL2
makedepends = git
makedepends = cmake
depends = protobuf3
provides = libarcus
conflicts = libarcus-git
- source = libarcus::git+https://github.com/Ultimaker/libArcus.git
- md5sums = SKIP
+ source = libarcus-15.06.03.tar.gz::https://github.com/Ultimaker/libArcus/archive/15.06.03.tar.gz
+ md5sums = c61fafaa82f71cef5e0f6780688f853e
pkgname = libarcus
diff --git a/PKGBUILD b/PKGBUILD
index 192aece533ee..d11a5f165a84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Yunhui Fu <yhfudev@gmail.com>
# Contributor: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=libarcus
-pkgver=424ae4f
+pkgver=15.06.03
pkgrel=1
pkgdesc="A library designed to facilitate the communication between Cura and its backend and similar code."
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'arm')
url="https://github.com/Ultimaker/libArcus"
license=('GPL2')
provides=('libarcus')
conflicts=('libarcus-git')
depends=('protobuf3')
makedepends=('git' 'cmake')
+
source=(
- "${pkgname}::git+https://github.com/Ultimaker/libArcus.git"
- #"${pkgname}-${pkgver}.tar.gz::https://github.com/Ultimaker/CuraEngine/archive/${pkgver}.tar.gz"
+ #"${pkgname}::git+https://github.com/Ultimaker/libArcus.git#commit=${pkgver}"
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/Ultimaker/libArcus/archive/${pkgver}.tar.gz"
)
md5sums=(
- 'SKIP'
+ 'c61fafaa82f71cef5e0f6780688f853e'
)
pkgver_git() {
@@ -34,11 +35,11 @@ pkgver_svn() {
echo ${ver:0:7}
}
-pkgver() {
- pkgver_git
-}
+#pkgver() {
+# pkgver_git
+#}
-build() {
+build4git() {
cd "${srcdir}/${pkgname}"
mkdir -p build
cd build
@@ -46,11 +47,34 @@ build() {
make
}
-package() {
+build4release() {
+ cd "${srcdir}/libArcus-${pkgver}"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_EXAMPLES=OFF ..
+ make
+}
+
+build() {
+ build4release
+}
+
+package4git() {
cd "${srcdir}/${pkgname}/build"
make DESTDIR="$pkgdir/" install
mv "$pkgdir/usr/local/lib64/" "$pkgdir/usr/lib/"
}
+package4release() {
+ cd "${srcdir}/libArcus-${pkgver}/build"
+ make DESTDIR="$pkgdir/" install
+
+ mv "$pkgdir/usr/local/lib64/" "$pkgdir/usr/lib/"
+}
+
+package() {
+ package4release
+}
+
# vim:set ts=2 sw=2 et: