summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2015-06-08 08:48:53 -0400
committerAdam Goldsmith2015-06-08 08:48:53 -0400
commit831a4b4aad2431833303b73fdeb66cc36ed116ac (patch)
tree2368df6adeb4ae5f633464c6f3fd1d64bb92cbdc
downloadaur-831a4b4aad2431833303b73fdeb66cc36ed116ac.tar.gz
migrating to AUR4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e358b0bc7fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libarcus-git
+ pkgdesc = A library designed to facilitate the communication between Cura and its backend and similar code.
+ pkgver = r84.3d6e94d
+ pkgrel = 1
+ url = https://github.com/Ultimaker/libArcus
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = protobuf3
+ provides = libarcus
+ conflicts = libarcus
+ source = git+https://github.com/Ultimaker/libArcus.git
+ md5sums = SKIP
+
+pkgname = libarcus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09d80d2acdcd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+pkgname=libarcus-git
+pkgver=r84.3d6e94d
+pkgrel=1
+pkgdesc="A library designed to facilitate the communication between Cura and its backend and similar code."
+arch=('i686' 'x86_64')
+url="https://github.com/Ultimaker/libArcus"
+license=('GPL2')
+provides=('libarcus')
+conflicts=('libarcus')
+depends=('protobuf3')
+makedepends=('git' 'cmake')
+source=('git+https://github.com/Ultimaker/libArcus.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd libArcus
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p libArcus/build
+ cd libArcus/build
+ cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_EXAMPLES=OFF ..
+ make
+}
+
+package() {
+ cd "$srcdir/libArcus/build"
+ make DESTDIR="$pkgdir/" install
+
+ mv "$pkgdir/usr/local/lib64/" "$pkgdir/usr/lib/"
+}
+
+# vim:set ts=2 sw=2 et: