summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2016-08-10 18:13:48 -0400
committerAdam Goldsmith2016-08-10 18:13:48 -0400
commit9f65c8344bf6e512383d40b56c794870fc9e876a (patch)
treeef99213336058eebda657f7bff5fde5ee2cf1448
parentaa5e962310e50f61c1f3c5ddabd0f3e2a2ad8787 (diff)
downloadaur-9f65c8344bf6e512383d40b56c794870fc9e876a.tar.gz
Remove patch, as it is no longer needed
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--site-packages-dir.patch18
3 files changed, 5 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2823770dfbb6..8c092a74e419 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jul 28 04:16:26 UTC 2016
+# Wed Aug 10 22:13:29 UTC 2016
pkgbase = libarcus-git
pkgdesc = A library designed to facilitate the communication between Cura and its backend and similar code.
- pkgver = r278.314ead4
+ pkgver = r290.1269723
pkgrel = 1
url = https://github.com/Ultimaker/libArcus
arch = i686
@@ -14,9 +14,7 @@ pkgbase = libarcus-git
provides = libarcus
conflicts = libarcus
source = git+https://github.com/Ultimaker/libArcus.git
- source = site-packages-dir.patch
md5sums = SKIP
- md5sums = a89dda56f6dbe4c29d9bf25abb186312
pkgname = libarcus-git
diff --git a/PKGBUILD b/PKGBUILD
index 188a615d8ac9..cd02ed2edeff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=libarcus-git
-pkgver=r278.314ead4
+pkgver=r290.1269723
pkgrel=1
pkgdesc="A library designed to facilitate the communication between Cura and its backend and similar code."
arch=('i686' 'x86_64')
@@ -10,20 +10,14 @@ provides=('libarcus')
conflicts=('libarcus')
depends=('protobuf3')
makedepends=('git' 'cmake')
-source=('git+https://github.com/Ultimaker/libArcus.git'
- 'site-packages-dir.patch')
-md5sums=('SKIP' 'a89dda56f6dbe4c29d9bf25abb186312')
+source=('git+https://github.com/Ultimaker/libArcus.git')
+md5sums=('SKIP')
pkgver() {
cd libArcus
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare(){
- cd libArcus
- patch -Np1 -i ../site-packages-dir.patch
-}
-
build() {
mkdir -p libArcus/build
cd libArcus/build
diff --git a/site-packages-dir.patch b/site-packages-dir.patch
deleted file mode 100644
index a5c843abf893..000000000000
--- a/site-packages-dir.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -11,12 +11,9 @@ set(REQUIRED_PROTOBUF_VERSION 3.0.0)
- find_package(Protobuf ${REQUIRED_PROTOBUF_VERSION} REQUIRED)
-
- if(BUILD_PYTHON)
-+ find_package( PythonInterp REQUIRED )
- set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
-- if(APPLE OR WIN32)
-- set(PYTHON_SITE_PACKAGES_DIR lib/python3.4/site-packages CACHE STRING "Directory to install Python bindings to")
-- else()
-- set(PYTHON_SITE_PACKAGES_DIR lib/python3/dist-packages CACHE STRING "Directory to install Python bindings to")
-- endif()
-+ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages CACHE STRING "Directory to install Python bindings to")
- find_package(SIP REQUIRED)
- include_directories(python/ src/ ${PYTHON_INCLUDE_DIR} ${SIP_INCLUDE_DIR})
- endif()
-