summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2016-02-15 10:15:03 -0500
committerAdam Goldsmith2016-02-15 10:27:31 -0500
commitc34142c7e69599a03128152e0034c7f168e79f09 (patch)
tree4a4964406712d9b212b821c60596a27ccfab621e
parentcb16abeebcc78b2969cc5adfb7d2a460cede7794 (diff)
downloadaur-c34142c7e69599a03128152e0034c7f168e79f09.tar.gz
Update site-packages-dir.patch for new CmakeLists.txt
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--site-packages-dir.patch19
3 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4d85c157162..a758aacc8ae0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Mon Feb 15 15:27:25 UTC 2016
pkgbase = libarcus-git
pkgdesc = A library designed to facilitate the communication between Cura and its backend and similar code.
- pkgver = r117.2ad9f67
+ pkgver = r237.22e3fea
pkgrel = 1
url = https://github.com/Ultimaker/libArcus
arch = i686
@@ -14,7 +16,7 @@ pkgbase = libarcus-git
source = git+https://github.com/Ultimaker/libArcus.git
source = site-packages-dir.patch
md5sums = SKIP
- md5sums = b8946cb96b180f82bdd8804b292ec5dd
+ md5sums = a89dda56f6dbe4c29d9bf25abb186312
pkgname = libarcus-git
diff --git a/PKGBUILD b/PKGBUILD
index 93150a2b1c66..de961e71ec12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=libarcus-git
-pkgver=r117.2ad9f67
+pkgver=r237.22e3fea
pkgrel=1
pkgdesc="A library designed to facilitate the communication between Cura and its backend and similar code."
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ depends=('protobuf3')
makedepends=('git' 'cmake')
source=('git+https://github.com/Ultimaker/libArcus.git'
'site-packages-dir.patch')
-md5sums=('SKIP' 'b8946cb96b180f82bdd8804b292ec5dd')
+md5sums=('SKIP' 'a89dda56f6dbe4c29d9bf25abb186312')
pkgver() {
cd libArcus
diff --git a/site-packages-dir.patch b/site-packages-dir.patch
index 16ba0ca11f96..a5c843abf893 100644
--- a/site-packages-dir.patch
+++ b/site-packages-dir.patch
@@ -1,15 +1,18 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -92,11 +92,7 @@ install(FILES
- )
+@@ -11,12 +11,9 @@ set(REQUIRED_PROTOBUF_VERSION 3.0.0)
+ find_package(Protobuf ${REQUIRED_PROTOBUF_VERSION} REQUIRED)
- if(INSTALL_PYTHON_PACKAGE)
+ if(BUILD_PYTHON)
++ find_package( PythonInterp REQUIRED )
+ set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
- if(APPLE OR WIN32)
-- install(FILES python/Arcus/__init__.py DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages/Arcus)
+- set(PYTHON_SITE_PACKAGES_DIR lib/python3.4/site-packages CACHE STRING "Directory to install Python bindings to")
- else()
-- install(FILES python/Arcus/__init__.py DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages/Arcus)
+- set(PYTHON_SITE_PACKAGES_DIR lib/python3/dist-packages CACHE STRING "Directory to install Python bindings to")
- endif()
-+ install(FILES python/Arcus/__init__.py DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages/Arcus)
++ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages CACHE STRING "Directory to install Python bindings to")
+ find_package(SIP REQUIRED)
+ include_directories(python/ src/ ${PYTHON_INCLUDE_DIR} ${SIP_INCLUDE_DIR})
endif()
-
- include(CPackConfig.cmake)
+