summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2015-10-16 16:46:43 -0400
committerAdam Goldsmith2015-10-16 16:46:43 -0400
commitcb16abeebcc78b2969cc5adfb7d2a460cede7794 (patch)
treeb5cfa8a8dfa143d0127f7759b9103e1ca3b7b10a
parentffa94ccbf897411ad3d7c2ddef81d341452aeaf6 (diff)
downloadaur-cb16abeebcc78b2969cc5adfb7d2a460cede7794.tar.gz
Fix install location
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--site-packages-dir.patch15
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a02551069c5a..c4d85c157162 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libarcus-git
pkgdesc = A library designed to facilitate the communication between Cura and its backend and similar code.
- pkgver = r96.a1692b9
+ pkgver = r117.2ad9f67
pkgrel = 1
url = https://github.com/Ultimaker/libArcus
arch = i686
@@ -12,7 +12,9 @@ pkgbase = libarcus-git
provides = libarcus
conflicts = libarcus
source = git+https://github.com/Ultimaker/libArcus.git
+ source = site-packages-dir.patch
md5sums = SKIP
+ md5sums = b8946cb96b180f82bdd8804b292ec5dd
pkgname = libarcus-git
diff --git a/PKGBUILD b/PKGBUILD
index 81c22983da10..93150a2b1c66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=libarcus-git
-pkgver=r96.a1692b9
+pkgver=r117.2ad9f67
pkgrel=1
pkgdesc="A library designed to facilitate the communication between Cura and its backend and similar code."
arch=('i686' 'x86_64')
@@ -10,18 +10,24 @@ provides=('libarcus')
conflicts=('libarcus')
depends=('protobuf3')
makedepends=('git' 'cmake')
-source=('git+https://github.com/Ultimaker/libArcus.git')
-md5sums=('SKIP')
+source=('git+https://github.com/Ultimaker/libArcus.git'
+ 'site-packages-dir.patch')
+md5sums=('SKIP' 'b8946cb96b180f82bdd8804b292ec5dd')
pkgver() {
cd libArcus
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare(){
+ cd libArcus
+ patch -Np1 -i ../site-packages-dir.patch
+}
+
build() {
mkdir -p libArcus/build
cd libArcus/build
- cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_EXAMPLES=OFF -DCMAKE_INSTALL_INCLUDEDIR="/usr/include" -DCMAKE_INSTALL_LIBDIR="/usr/lib" -DPYTHON_SITE_PACKAGES_DIR="/usr/lib/python3.4/site-packages/" ..
+ cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_EXAMPLES=OFF -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
diff --git a/site-packages-dir.patch b/site-packages-dir.patch
new file mode 100644
index 000000000000..16ba0ca11f96
--- /dev/null
+++ b/site-packages-dir.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -92,11 +92,7 @@ install(FILES
+ )
+
+ if(INSTALL_PYTHON_PACKAGE)
+- if(APPLE OR WIN32)
+- install(FILES python/Arcus/__init__.py DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages/Arcus)
+- else()
+- install(FILES python/Arcus/__init__.py DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages/Arcus)
+- endif()
++ install(FILES python/Arcus/__init__.py DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages/Arcus)
+ endif()
+
+ include(CPackConfig.cmake)