summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2015-08-23 23:44:33 -0400
committerAdam Goldsmith2015-08-23 23:44:33 -0400
commitffa94ccbf897411ad3d7c2ddef81d341452aeaf6 (patch)
treef845ddf466acd12233076e8587714f5ee6618547
parent831a4b4aad2431833303b73fdeb66cc36ed116ac (diff)
downloadaur-ffa94ccbf897411ad3d7c2ddef81d341452aeaf6.tar.gz
fix python package install location
uses CMake variables instead of manually moving things around
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e358b0bc7fa..a02551069c5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libarcus-git
pkgdesc = A library designed to facilitate the communication between Cura and its backend and similar code.
- pkgver = r84.3d6e94d
+ pkgver = r96.a1692b9
pkgrel = 1
url = https://github.com/Ultimaker/libArcus
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 09d80d2acdcd..81c22983da10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=libarcus-git
-pkgver=r84.3d6e94d
+pkgver=r96.a1692b9
pkgrel=1
pkgdesc="A library designed to facilitate the communication between Cura and its backend and similar code."
arch=('i686' 'x86_64')
@@ -21,15 +21,13 @@ pkgver() {
build() {
mkdir -p libArcus/build
cd libArcus/build
- cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_EXAMPLES=OFF ..
+ cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_EXAMPLES=OFF -DCMAKE_INSTALL_INCLUDEDIR="/usr/include" -DCMAKE_INSTALL_LIBDIR="/usr/lib" -DPYTHON_SITE_PACKAGES_DIR="/usr/lib/python3.4/site-packages/" ..
make
}
package() {
cd "$srcdir/libArcus/build"
make DESTDIR="$pkgdir/" install
-
- mv "$pkgdir/usr/local/lib64/" "$pkgdir/usr/lib/"
}
# vim:set ts=2 sw=2 et: