summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Iooss2016-08-19 14:23:58 +0200
committerAlexandre Iooss2016-08-19 14:23:58 +0200
commit8e3f240404e2d854b58532dbcebc0f5a6866a5b9 (patch)
tree5b572b41049a843dd45b7f3cb9f2b659b14608a8
parent6f7a34571cdee9dd018e93fcee5ff6df1b84d5c5 (diff)
downloadaur-8e3f240404e2d854b58532dbcebc0f5a6866a5b9.tar.gz
Add patchs
-rw-r--r--.SRCINFO4
-rw-r--r--0002-Fix-some-warnings.patch31
-rw-r--r--PKGBUILD5
3 files changed, 38 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a07762f701d2..c0f969bf49ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libardiscovery-git
pkgdesc = ARSDK Discovery and Connection Management Layer
pkgver = r423.cb4f019
- pkgrel = 1
+ pkgrel = 2
url = http://developer.parrot.com/
arch = x86_64
license = custom
@@ -14,11 +14,13 @@ pkgbase = libardiscovery-git
source = libardiscovery::git+https://github.com/Parrot-Developers/libARDiscovery
source = libardiscovery-Makefile
source = 0001-Fix-json-c.patch
+ source = 0002-Fix-some-warnings.patch
source = Config-linux-config.h
source = LICENSE
sha256sums = SKIP
sha256sums = 0904602bdd8ae1d6b1a5923f2c16512dbdb90acddef0c35b7726831bad533c1c
sha256sums = 74300421b1799e0a32dc62eeded41b56a756b9c4ba95ad42402373e9ea9c3c44
+ sha256sums = 3f06925dc6c5ab160f4d021cf570591dec1ea7616439a3c59f0b058d8c45b0a9
sha256sums = 5956b54ef47ad26df51991a4aa7002abdcb524a51b455d040f55b4d11a4f44a7
sha256sums = 1771e95329e9cb2bed04e023e330af3d558d0f13c0c1c5de0581f2880f149deb
diff --git a/0002-Fix-some-warnings.patch b/0002-Fix-some-warnings.patch
new file mode 100644
index 000000000000..a0a52d5665b9
--- /dev/null
+++ b/0002-Fix-some-warnings.patch
@@ -0,0 +1,31 @@
+--- a/libardiscovery/Sources/ARDISCOVERY_Connection.c
++++ b/libardiscovery/Sources/ARDISCOVERY_Connection.c
+@@ -866,7 +866,7 @@ static eARDISCOVERY_ERROR ARDISCOVERY_Connection_RxPending (ARDISCOVERY_Connecti
+ else
+ {
+ if ((readSize == 0 || readSize == -1) &&
+- (errno == EAGAIN || errno == EWOULDBLOCK))
++ (errno == EAGAIN))
+ {
+ ARSAL_PRINT(ARSAL_PRINT_DEBUG, ARDISCOVERY_CONNECTION_TAG, "No more data to read");
+ // Nothing to do here, it just means that we had a size which is a multiple of ARDISCOVERY_CONNECTION_RX_BUFFER_SIZE
+@@ -902,7 +902,7 @@ static eARDISCOVERY_ERROR ARDISCOVERY_Connection_RxPending (ARDISCOVERY_Connecti
+ else
+ {
+ if ((readSize == 0 || readSize == -1) &&
+- (errno == EAGAIN || errno == EWOULDBLOCK))
++ (errno == EAGAIN))
+ {
+ ARSAL_PRINT(ARSAL_PRINT_DEBUG, ARDISCOVERY_CONNECTION_TAG, "No more data to read");
+ // Nothing to do here, it just means that we had a size which is a multiple of ARDISCOVERY_CONNECTION_RX_BUFFER_SIZE
+--- a/libardiscovery/Sources/ARDISCOVERY_Connection.h
++++ b/libardiscovery/Sources/ARDISCOVERY_Connection.h
+@@ -40,7 +40,7 @@
+ typedef struct ARDISCOVERY_Connection_ComData_t
+ {
+ uint8_t *buffer; /**< data buffer */
+- int32_t size; /**< size of the data */
++ uint32_t size; /**< size of the data */
+ int32_t capacity; /**< size allocated of the data buffer */
+ } ARDISCOVERY_Connection_ComData_t;
+
diff --git a/PKGBUILD b/PKGBUILD
index 608fe7913666..082634c8f440 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libardiscovery-git
pkgver=r423.cb4f019
-pkgrel=1
+pkgrel=2
pkgdesc="ARSDK Discovery and Connection Management Layer"
arch=(x86_64)
url="http://developer.parrot.com/"
@@ -20,11 +20,13 @@ install=
source=('libardiscovery::git+https://github.com/Parrot-Developers/libARDiscovery'
'libardiscovery-Makefile'
'0001-Fix-json-c.patch'
+ '0002-Fix-some-warnings.patch'
'Config-linux-config.h'
'LICENSE')
sha256sums=('SKIP'
'0904602bdd8ae1d6b1a5923f2c16512dbdb90acddef0c35b7726831bad533c1c'
'74300421b1799e0a32dc62eeded41b56a756b9c4ba95ad42402373e9ea9c3c44'
+ '3f06925dc6c5ab160f4d021cf570591dec1ea7616439a3c59f0b058d8c45b0a9'
'5956b54ef47ad26df51991a4aa7002abdcb524a51b455d040f55b4d11a4f44a7'
'1771e95329e9cb2bed04e023e330af3d558d0f13c0c1c5de0581f2880f149deb')
@@ -39,6 +41,7 @@ prepare() {
# Patch to use latest json-c
patch -p1 -i "$srcdir/0001-Fix-json-c.patch"
+ patch -p1 -i "$srcdir/0002-Fix-some-warnings.patch"
}
build() {