summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrejs Mivreņiks2015-07-20 18:11:14 +0300
committerAndrejs Mivreņiks2015-07-20 18:11:14 +0300
commit073b3cc3f70efe9186b7c98bb3ce6ebc4f6ca392 (patch)
tree38cd9512c702ffa8f3e510c3295320354d87512b
parentd39792acddd128d4b0ac05b7fdc4cab735dfa05c (diff)
downloadaur-073b3cc3f70efe9186b7c98bb3ce6ebc4f6ca392.tar.gz
Update: v0.1.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 6 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cdb9da77d48..506479872988 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libasl
pkgdesc = Multiphysics simulation software package (Advanced Simulation Library)
- pkgver = 0.1.3
+ pkgver = 0.1.4
pkgrel = 1
url = http://asl.org.il/
arch = i686
@@ -14,8 +14,8 @@ pkgbase = libasl
optdepends = libmatio: Matlab file format support (should be installed before build)
conflicts = libasl-git
options = !buildflags
- source = libasl-0.1.3.tar.gz::https://github.com/AvtechScientific/ASL/archive/v0.1.3.tar.gz
- sha256sums = 7d5214dcd0da84695fe967038f25ced9cbd02075515926f485003c7f915cf0cf
+ source = libasl-0.1.4.tar.gz::https://github.com/AvtechScientific/ASL/archive/v0.1.4.tar.gz
+ sha256sums = a8ec82e7ecc05911156ce08dd3f4c571c7dbc4d0dc30950cd8130a197d66da4f
pkgname = libasl
diff --git a/PKGBUILD b/PKGBUILD
index 9425fe755b55..d5fc3bcdfb8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Andrejs Mivreņiks <gim at fastmail dot fm>
pkgname=libasl
-pkgver=0.1.3
+pkgver=0.1.4
pkgrel=1
pkgdesc='Multiphysics simulation software package (Advanced Simulation Library)'
arch=('i686' 'x86_64')
@@ -12,19 +12,12 @@ optdepends=('libmatio: Matlab file format support (should be installed before bu
conflicts=('libasl-git')
options=(!buildflags)
source=("$pkgname-$pkgver.tar.gz::https://github.com/AvtechScientific/ASL/archive/v${pkgver}.tar.gz")
-sha256sums=('7d5214dcd0da84695fe967038f25ced9cbd02075515926f485003c7f915cf0cf')
-
-prepare() {
- cd "$srcdir/ASL-$pkgver"
- # Add fpermissive flag to avoid some build issues
- # https://github.com/AvtechScientific/ASL/issues/2
- sed -i "s/set(CMAKE_CXX_STANDARD 11)/set(CMAKE_CXX_STANDARD 11)\n\tset(CMAKE_CXX_FLAGS "-fpermissive")/g" CMakeLists.txt
-}
+sha256sums=('a8ec82e7ecc05911156ce08dd3f4c571c7dbc4d0dc30950cd8130a197d66da4f')
build() {
cd "$srcdir/ASL-$pkgver"
mkdir -p build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -G "Unix Makefiles" ../
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ../
make
}