summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVadim Yanitskiy2023-09-13 19:12:10 +0700
committerVadim Yanitskiy2023-09-13 19:12:10 +0700
commitc2f4e8c25109ade431b98b67b10f08111ebf6777 (patch)
treeb110b4fd2a6e48e0eedd99da7bf34d368a49abec
parent624f490197faace13b32df7601766f3a42966b1f (diff)
downloadaur-c2f4e8c25109ade431b98b67b10f08111ebf6777.tar.gz
New package: stable release v0.9.36
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 19 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f5fa41ffd90..406c75bbcd0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-pkgbase = libasn1c-git
+pkgbase = libasn1c
pkgdesc = runtime library of Lev Walkin's asn1c split out as separate library
- pkgver = 0.9.31.r3.g5e00d6f
+ pkgver = 0.9.36
pkgrel = 1
- url = http://cgit.osmocom.org/libasn1c
+ url = https://cgit.osmocom.org/libasn1c
arch = i686
arch = x86_64
arch = aarch64
arch = armv7h
license = GPL
- makedepends = git
depends = talloc
- provides = libasn1c
- conflicts = libasn1c
- source = git+https://git.osmocom.org/libasn1c
- sha256sums = SKIP
-
-pkgname = libasn1c-git
+ provides = libasn1c.so=0.9.36
+ conflicts = libasn1c-git
+ source = https://downloads.osmocom.org/releases/libasn1c/libasn1c-0.9.36.tar.bz2
+ sha256sums = ec3979be22d184f806e2997e7c5f02bad56ce759841c66c25b844f440a2538d4
+pkgname = libasn1c
diff --git a/PKGBUILD b/PKGBUILD
index eea7446381ed..0de00b1cf046 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,27 @@
-# Maintainer: Josef Miegl <josef@miegl.cz>
+# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
+# Contributor: Josef Miegl <josef@miegl.cz>
-pkgname=libasn1c-git
-pkgver=0.9.31.r3.g5e00d6f
+pkgname=libasn1c
+pkgver=0.9.36
pkgrel=1
pkgdesc="runtime library of Lev Walkin's asn1c split out as separate library"
-url="http://cgit.osmocom.org/libasn1c"
+url="https://cgit.osmocom.org/libasn1c"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
depends=('talloc')
-makedepends=('git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=("git+https://git.osmocom.org/${pkgname%-git}")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "${pkgname%-git}"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "${pkgname%-git}"
- autoreconf -f -i
-}
+provides=("libasn1c.so=${pkgver}")
+conflicts=("${pkgname}-git")
+source=("https://downloads.osmocom.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('ec3979be22d184f806e2997e7c5f02bad56ce759841c66c25b844f440a2538d4')
build() {
- cd "${pkgname%-git}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}
package() {
- cd "${pkgname%-git}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR=${pkgdir} install
}