summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Miegl2019-02-06 18:01:57 +0100
committerJosef Miegl2019-02-06 18:01:57 +0100
commitfbdce893ccfba7680c9009998630094e61556f99 (patch)
tree5515e9cc3fcb0b923d50dc187ba008d6c6a1c60e
downloadaur-fbdce893ccfba7680c9009998630094e61556f99.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..714c7d3dd8e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libasn1c-git
+ pkgdesc = runtime library of Lev Walkin's asn1c split out as separate library
+ pkgver = 0.9.31.3.g5e00d6f
+ pkgrel = 1
+ url = http://cgit.osmocom.org/libasn1c/
+ arch = any
+ license = GPL
+ provides = libasn1c
+ conflicts = libasn1c
+ source = git://git.osmocom.org/libasn1c
+ sha256sums = SKIP
+
+pkgname = libasn1c-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eda73f60517c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Josef Miegl <josef@miegl.cz>
+
+pkgname=libasn1c-git
+_pkgname=libasn1c
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+pkgver=0.9.31.3.g5e00d6f
+pkgrel=1
+pkgdesc="runtime library of Lev Walkin's asn1c split out as separate library"
+url="http://cgit.osmocom.org/libasn1c/"
+arch=('any')
+license=(GPL)
+source=("git://git.osmocom.org/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR=${pkgdir} install
+}