summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorweearc2022-05-30 15:47:13 +0800
committerweearc2022-05-30 15:47:13 +0800
commit460e1f67c783b2486fe0c76baa2c5cf932370f6b (patch)
treeca7f1d3aea723c20727e2d526c28ccb89f1d6dfb
parent645e5bc9c8cd1327867bbb82ad73a5452e88dc2a (diff)
downloadaur-460e1f67c783b2486fe0c76baa2c5cf932370f6b.tar.gz
remove binary
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--libaxon.install7
-rw-r--r--libaxon@.service2
-rw-r--r--libaxon_user.service2
5 files changed, 23 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adb5a167ce21..6359c95669f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libaxon-bin
pkgdesc = oicq backend
pkgver = 1.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/axon-oicq/axon
install = libaxon.install
arch = x86_64
@@ -14,13 +14,13 @@ pkgbase = libaxon-bin
optdepends = systemd: For init systemd instead of openrc
provides = axon
provides = libaxon
- source = https://github.com/axon-oicq/axon/releases/download/v1.0.1/axon-1.0.1-linux-x86_64
+ source = http://ci.hackflow.org/job/oicq-axon/8/artifact/dist/oicq-axon-linux-x64.gz
source = libaxon.install
source = libaxon@.service
source = libaxon_user.service
- sha256sums = edee85740af52652bb2325ad7b1061a3dca101e078a290f515d5c0890ba89928
- sha256sums = 7272853b3cb6b2a787f394ae803a1d731cdd8c7c552c69445a8f7a2b47ba3ab9
- sha256sums = ab5586c4cf93b1cbd77d57c31ce0d3da9d5888301c9b8638dab36e2f71299736
- sha256sums = c28f69e0879b560553750adfd7c456cae96d12e4a6cf63d590e28059caab12ad
+ sha256sums = 614cb0340407dda56de94e560e14261885df208d2c3cde4f0a068e30110e0c22
+ sha256sums = 6251c002f240591219638b1ef487f532a2874cef836f0ec91c62643416de7bca
+ sha256sums = 366a164f08ed21363b75ccd946a8e889d02b1c3f421dd0d9ddb73c23d3ae7058
+ sha256sums = 7e03b55d48c162d9047c98055b0a3825c174dd36804f04af39db56d038ce9e03
pkgname = libaxon-bin
diff --git a/PKGBUILD b/PKGBUILD
index c7a5e69f22e3..3e58a1178a9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=libaxon-bin
_pkgname=libaxon
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc='oicq backend'
url='https://github.com/axon-oicq/axon'
license=(Unlicense)
@@ -17,18 +17,18 @@ optdepends=('pidgin: For GUI usage of oicq'
'purple-oicq-git: purple plugin for ocqi, git version'
'systemd: For init systemd instead of openrc'
)
-source=("https://github.com/axon-oicq/axon/releases/download/v1.0.1/axon-1.0.1-linux-x86_64"
+source=("http://ci.hackflow.org/job/oicq-axon/8/artifact/dist/oicq-axon-linux-x64.gz"
"libaxon.install"
"libaxon@.service"
"libaxon_user.service")
-sha256sums=('edee85740af52652bb2325ad7b1061a3dca101e078a290f515d5c0890ba89928'
- '7272853b3cb6b2a787f394ae803a1d731cdd8c7c552c69445a8f7a2b47ba3ab9'
- 'ab5586c4cf93b1cbd77d57c31ce0d3da9d5888301c9b8638dab36e2f71299736'
- 'c28f69e0879b560553750adfd7c456cae96d12e4a6cf63d590e28059caab12ad'
- )
+sha256sums=("614cb0340407dda56de94e560e14261885df208d2c3cde4f0a068e30110e0c22"
+ "6251c002f240591219638b1ef487f532a2874cef836f0ec91c62643416de7bca"
+ "366a164f08ed21363b75ccd946a8e889d02b1c3f421dd0d9ddb73c23d3ae7058"
+ "7e03b55d48c162d9047c98055b0a3825c174dd36804f04af39db56d038ce9e03"
+ )
package() {
- install -Dm755 axon-${pkgver}-linux-${CARCH} ${pkgdir}/usr/bin/${_pkgname}
+ install -Dm755 oicq-axon-linux-x64 ${pkgdir}/usr/bin/${_pkgname}
install -Dm644 "libaxon@.service" "${pkgdir}/usr/lib/systemd/system/libaxon@.service"
install -Dm644 "libaxon_user.service" "${pkgdir}/usr/lib/systemd/user/libaxon.service"
}
diff --git a/libaxon.install b/libaxon.install
index a4a2735100c2..f30761d7014c 100644
--- a/libaxon.install
+++ b/libaxon.install
@@ -1,5 +1,7 @@
post_install(){
echo "=========================="
+ echo "Run 'systemd daemon-reload' first"
+ echo ""
echo "Systemd service can be enabled via command:"
echo ""
echo "systemctl enable libaxon@USERNAME.service"
@@ -18,6 +20,11 @@ post_upgrade(){
}
+pre_remove(){
+ echo "Stop systemd service..."
+ systemctl stop libaxon@${whoami}.serivce
+}
+
post_remove(){
echo "==> Restate systemd service via command: "
echo "==> systemctl daemon-reload"
diff --git a/libaxon@.service b/libaxon@.service
index 5b4febe8b8ab..ce5563f2e2ed 100644
--- a/libaxon@.service
+++ b/libaxon@.service
@@ -9,7 +9,7 @@ After=systemd-logind.service
Type=exec
User=%i
Restart=on-abort
-ExecStart=/usr/bin/libaxon
+ExecStart=/usr/bin/libaxon -c /home/%i/.cache/libaxon/
[Install]
WantedBy=multi-user.target
diff --git a/libaxon_user.service b/libaxon_user.service
index 94e3b67e7d51..7efa3b9be839 100644
--- a/libaxon_user.service
+++ b/libaxon_user.service
@@ -5,7 +5,7 @@ After=network.target
[Service]
Type=exec
Restart=on-abort
-ExecStart=/usr/bin/libaxon
+ExecStart=/usr/bin/libaxon -c /home/%i/.cache/libaxon/
[Install]
WantedBy=default.target