summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-19 00:20:37 +0100
committerNarrat2020-01-19 00:20:37 +0100
commit305fce1ecc456380fafd7f61668f9df998b4a237 (patch)
tree5def3f7a8f1bac24ac0bb065cc62115902b0d691
parent0ecb6741320594ff9c69e89e71d019dbebda07e0 (diff)
downloadaur-305fce1ecc456380fafd7f61668f9df998b4a237.tar.gz
update to 0.98.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
2 files changed, 16 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e25b8cf0090..50be2df52baa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = libb2
pkgdesc = C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp hash functions
- pkgver = 0.0.17.g0d7015f
+ pkgver = 0.98.1
pkgrel = 1
url = https://blake2.net/
arch = i686
arch = x86_64
license = custom:CC0
- makedepends = git
- source = git+https://github.com/BLAKE2/libb2
- sha256sums = SKIP
+ depends = gcc-libs
+ source = https://github.com/BLAKE2/libb2/releases/download/v0.98.1/libb2-0.98.1.tar.gz
+ sha256sums = 53626fddce753c454a3fea581cbbc7fe9bbcf0bc70416d48fdbbf5d87ef6c72e
pkgname = libb2
diff --git a/PKGBUILD b/PKGBUILD
index fe4b96006138..3f03686ff3e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,28 @@
-# Maintainer: Jesin <Jesin00@gmail.com>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Jesin <Jesin00@gmail.com>
+
pkgname=libb2
-pkgver=0.0.17.g0d7015f
+pkgver=0.98.1
pkgrel=1
arch=(i686 x86_64)
pkgdesc='C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp hash functions'
url=https://blake2.net/
license=(custom:CC0)
-makedepends=(git)
-source=("git+https://github.com/BLAKE2/$pkgname")
-sha256sums=(SKIP)
+depends=(gcc-libs)
+source=(https://github.com/BLAKE2/libb2/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('53626fddce753c454a3fea581cbbc7fe9bbcf0bc70416d48fdbbf5d87ef6c72e')
# libb2's build system discards the $CFLAGS variable.
# We can get around this by putting those flags in $CC.
export CC="${CC-cc} $CFLAGS"
prepare() {
- cd "$pkgname"
- # If there are no tags, tag the initial commit so pkgver() can work.
- [ -n "$(git tag)" ] || git tag 0.0 "$(git rev-list --max-parents=0 --reverse HEAD | head -n1)"
+ cd "$pkgname-$pkgver"
autoreconf -fisv
}
-pkgver() {
- cd "$pkgname"
- local v="$(git describe --tags)"
- printf %s\\n "${v//-/.}"
-}
-
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
./configure --prefix=/usr --disable-static --enable-shared "--build=$CHOST" #--disable-native --enable-fat
# Uncomment the flags at the end of the previous line if you intend
# to distribute the binary package to other computers.
@@ -36,12 +30,12 @@ build() {
}
check() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make check
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make "DESTDIR=$pkgdir" install
- install -Dm644 "-t$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ install -Dm644 "-t$pkgdir/usr/share/licenses/$pkgname" COPYING
}