summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2020-03-30 12:57:50 +1100
committerStephen Gregoratto2020-03-30 12:57:50 +1100
commitaf3fd13af740289a385460239a4eb01594dde131 (patch)
tree98bf6cb1245b9b2d1944d2d35f493db4a715e14e
parent276c5e84a7e1cca3e4b2ad4e1f54490c3cb38a13 (diff)
downloadaur-af3fd13af740289a385460239a4eb01594dde131.tar.gz
Add glibc dependancy, .gitignore
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42f739e3459a..0015a8e04eee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libbaseencode
- pkgdesc = Library written in C for encoding and decoding data using base32 or base64 (RFC-4648)
+ pkgdesc = C library for encoding/decoding base32 and base64 data (RFC-4648)
pkgver = 1.0.9
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/paolostivanin/libbaseencode
arch = i686
arch = x86_64
@@ -9,9 +9,10 @@ pkgbase = libbaseencode
arch = armv7h
license = APACHE
makedepends = cmake
+ depends = glibc
options = !strip
- source = https://github.com/paolostivanin/libbaseencode/archive/v1.0.9.tar.gz
- source = https://github.com/paolostivanin/libbaseencode/releases/download/v1.0.9/v1.0.9.tar.gz.asc
+ source = libbaseencode-1.0.9.tar.gz::https://github.com/paolostivanin/libbaseencode/archive/v1.0.9.tar.gz
+ source = libbaseencode-1.0.9.tar.gz.asc::https://github.com/paolostivanin/libbaseencode/releases/download/v1.0.9/v1.0.9.tar.gz.asc
validpgpkeys = 060C6B7D3869F148C4C4ACD43C9BE9B64EC1EA64
sha256sums = a183d7cf30d931b2a078d6f0ef64616b71ab26f9258e5f4e191778c7ace7175d
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f9ba3007cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index c40e5af4a848..52f835ba030a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: Paolo Stivanin <info at paolostivanin dot com>
-# Maintainer: KingofToasters <themanhimself at sgregoratto dot me>
+# Maintainer: Stephen Gregoratto <dev at sgregoratto dot me>
pkgname=libbaseencode
pkgver=1.0.9
-pkgrel=2
-pkgdesc='Library written in C for encoding and decoding data using base32 or base64 (RFC-4648)'
+pkgrel=3
+pkgdesc='C library for encoding/decoding base32 and base64 data (RFC-4648)'
url="https://github.com/paolostivanin/libbaseencode"
license=('APACHE')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+depends=('glibc')
makedepends=('cmake')
options=('!strip')
validpgpkeys=('060C6B7D3869F148C4C4ACD43C9BE9B64EC1EA64')
-source=("$url/archive/v$pkgver.tar.gz"
- "$url/releases/download/v$pkgver/v$pkgver.tar.gz.asc")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "$pkgname-$pkgver.tar.gz.asc::$url/releases/download/v$pkgver/v$pkgver.tar.gz.asc")
sha256sums=('a183d7cf30d931b2a078d6f0ef64616b71ab26f9258e5f4e191778c7ace7175d'
'SKIP')
-build() {
- cd "${pkgname}-${pkgver}"
+build() {
+ cd "$pkgname-$pkgver"
mkdir build && cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
make
}
package() {
- cd "${pkgname}-${pkgver}/build"
+ cd "$pkgname-$pkgver/build"
make DESTDIR="$pkgdir" install
}