summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2022-12-03 21:52:28 +0100
committerFerdinand Bachmann2022-12-03 21:52:28 +0100
commita38dadea4fb3edd6bdd4d15c53c3d45c8e17b444 (patch)
tree0f5927ffe08e9c2104976696513cae79d02844a1
parent84785ab95c962ab92681bed1e9297fdacbe98d6d (diff)
downloadaur-a38dadea4fb3edd6bdd4d15c53c3d45c8e17b444.tar.gz
update PKGBUILD to fix new zip layout
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c921ee968a5..3bf3f80d010b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libbass_fx
pkgdesc = BASS audio library - Effects Add-On
pkgver = 2.4.12.6
- pkgrel = 2
+ pkgrel = 3
url = http://www.un4seen.com/
arch = i686
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = libbass_fx
depends = libbass
source = https://www.un4seen.com/files/z/0/bass_fx24-linux.zip
source = LICENSE
- sha256sums = a98eb81bade52bdcc2d59e8d6803dea97ed4060f3b98e7097f05db1f91481cb5
+ sha256sums = 1ee97610bc2768357c4c344c0d7a058ac95edf51804c391fdcf7644762bd413b
sha256sums = f7bc36320110c8fd2f87c6d2bb5df6d2231ca9ab31a299b1565de63f7681cc83
source_armv6h = bass_fx24-linux-armv6h.zip::https://www.un4seen.com/files/z/0/bass_fx24-linux-arm.zip
sha256sums_armv6h = 84968a3d6afafaa13d7a4e3b6a4d9e787c49067471118f7d084d13caadb551f5
diff --git a/PKGBUILD b/PKGBUILD
index 5d4a26a00178..0f60d133a31c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ferdinand "yrlf" Bachmann <theferdi265@gmail.com>
pkgname=libbass_fx
pkgver=2.4.12.6
-pkgrel=2
+pkgrel=3
pkgdesc="BASS audio library - Effects Add-On"
arch=(i686 x86_64 armv6h armv7h aarch64)
url="http://www.un4seen.com/"
@@ -12,7 +12,7 @@ source=(
https://www.un4seen.com/files/z/0/bass_fx24-linux.zip
LICENSE
)
-sha256sums=('a98eb81bade52bdcc2d59e8d6803dea97ed4060f3b98e7097f05db1f91481cb5'
+sha256sums=('1ee97610bc2768357c4c344c0d7a058ac95edf51804c391fdcf7644762bd413b'
'f7bc36320110c8fd2f87c6d2bb5df6d2231ca9ab31a299b1565de63f7681cc83')
sha256sums_armv6h=('84968a3d6afafaa13d7a4e3b6a4d9e787c49067471118f7d084d13caadb551f5')
sha256sums_armv7h=('84968a3d6afafaa13d7a4e3b6a4d9e787c49067471118f7d084d13caadb551f5')
@@ -38,10 +38,10 @@ package () {
case "$CARCH" in
i686)
- install -D -m755 libbass_fx.so "$pkgdir/usr/lib/libbass_fx.so"
+ install -D -m755 libs/x86/libbass_fx.so "$pkgdir/usr/lib/libbass_fx.so"
;;
x86_64)
- install -D -m755 x64/libbass_fx.so "$pkgdir/usr/lib/libbass_fx.so"
+ install -D -m755 libs/x86_64/libbass_fx.so "$pkgdir/usr/lib/libbass_fx.so"
;;
armv6h|armv7h)
install -D -m755 $CARCH/hardfp/libbass_fx.so "$pkgdir/usr/lib/libbass_fx.so"