summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortheFerdi2652017-09-27 12:19:38 +0200
committertheFerdi2652017-09-27 12:19:38 +0200
commitb9a2dcdca48119c5d53a42dd1ae807854c35e3ec (patch)
treea58139ecd0755b4fbb8d69aa25eafbde9eed7b6c
downloadaur-b9a2dcdca48119c5d53a42dd1ae807854c35e3ec.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--LICENSE60
-rw-r--r--PKGBUILD47
-rw-r--r--bass_fx24-linux.zipbin0 -> 197676 bytes
-rw-r--r--libbass_fx-2.4.11.1-1-x86_64.pkg.tar.xzbin0 -> 143700 bytes
5 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf292816fea8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Wed Sep 27 10:19:33 UTC 2017
+pkgbase = libbass_fx
+ pkgdesc = BASS audio library - Effects Add-On
+ pkgver = 2.4.11.1
+ pkgrel = 1
+ url = http://www.un4seen.com/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = custom
+ depends = alsa-lib
+ depends = unzip
+ depends = libbass
+ source = https://www.un4seen.com/files/z/0/bass_fx24-linux.zip
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = f7bc36320110c8fd2f87c6d2bb5df6d2231ca9ab31a299b1565de63f7681cc83
+ source_armv6h = bass_fx24-linux-armv6h.zip::https://www.un4seen.com/files/z/0/bass_fx24-linux-arm.zip
+ sha256sums_armv6h = SKIP
+ source_armv7h = bass_fx24-linux-armv7h.zip::https://www.un4seen.com/files/z/0/bass_fx24-linux-arm.zip
+ sha256sums_armv7h = SKIP
+
+pkgname = libbass_fx
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b12b1cb27805
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,60 @@
+BASS is free for non-commercial use. If you are a non-commercial entity
+(eg. an individual) and you are not making any money from your product
+(through sales/advertising/etc), then you can use BASS in it for free.
+If you wish to use BASS in commercial products, then please also see the
+next section.
+
+TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, BASS IS PROVIDED
+"AS IS", WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED,
+INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY
+AND/OR FITNESS FOR A PARTICULAR PURPOSE. THE AUTHORS SHALL NOT BE HELD
+LIABLE FOR ANY DAMAGE THAT MAY RESULT FROM THE USE OF BASS. YOU USE
+BASS ENTIRELY AT YOUR OWN RISK.
+
+Usage of BASS indicates that you agree to the above conditions.
+
+All trademarks and other registered names contained in the BASS
+package are the property of their respective owners.
+
+Commercial licensing
+--------------------
+BASS is available for use in your commercial products. The licence
+types available are as follows:
+
+SHAREWARE: Allows the usage of BASS in an unlimited number of your
+shareware ("try before you buy") products, which must sell for no more
+than 40 Euros each. Non-shareware products are also permitted, but the
+product price limit is 10 Euros in that case. The price limit can be
+raised by purchasing duplicate licences, eg. 2 licences doubles it. If
+you are an individual (not a corporation) making and selling your own
+software, this is the licence for you.
+
+SINGLE COMMERCIAL: Allows the usage of BASS in one commercial product.
+
+UNLIMITED COMMERCIAL: Allows the usage of BASS in an unlimited number
+of your commercial products. This licence is on a per-site basis, eg.
+if you are creating products with BASS at 2 sites/locations, then 2
+licences are required.
+
+Please note the products must be end-user products, eg. not components
+used by other products.
+
+These licences only cover your own software, not the publishing of
+other's software. If you publish other's software, its developers (or
+the software itself) will need to be licensed to use BASS.
+
+These licences are on a per-platform basis, with reductions available
+when licensing for multiple platforms. In all cases there are no royalties
+to pay, and you can use future BASS updates without further cost.
+
+These licences do not allow reselling/sublicensing of BASS. For example,
+if a product is a development system, the users of said product are not
+licensed to use BASS in their productions; they will need their own
+licences.
+
+If the standard licences do not meet your requirements, or if you have
+any questions, please get in touch (email: bass@un4seen.com).
+
+Visit the BASS website for the latest pricing:
+
+ www.un4seen.com
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6fbe08efcb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Ferdinand "yrlf" Bachmann <theferdi265@gmail.com>
+pkgname=libbass_fx
+pkgver=2.4.11.1
+pkgrel=1
+pkgdesc="BASS audio library - Effects Add-On"
+arch=(i686 x86_64 armv6h armv7h aarch64)
+url="http://www.un4seen.com/"
+license=(custom)
+depends=(alsa-lib unzip libbass)
+
+source=(https://www.un4seen.com/files/z/0/bass_fx24-linux.zip LICENSE)
+sha256sums=('SKIP'
+ 'f7bc36320110c8fd2f87c6d2bb5df6d2231ca9ab31a299b1565de63f7681cc83')
+
+source_armv6h=(bass_fx24-linux-armv6h.zip::https://www.un4seen.com/files/z/0/bass_fx24-linux-arm.zip)
+sha256sums_armv6h=('SKIP')
+source_armv7h=(bass_fx24-linux-armv7h.zip::https://www.un4seen.com/files/z/0/bass_fx24-linux-arm.zip)
+sha256sums_armv7h=('SKIP')
+
+build () {
+ unzip -q bass_fx24-linux.zip -d "$srcdir/$pkgname-$pkgver"
+
+ if [[ -e "bass_fx24-linux-$CARCH.zip" ]]; then
+ unzip -q bass_fx24-linux-$CARCH.zip -d "$srcdir/$pkgname-$pkgver/$CARCH"
+ fi
+}
+
+package () {
+ install -D -m644 "$startdir/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ case "$CARCH" in
+ i686)
+ install -D -m755 libbass_fx.so "$pkgdir/usr/lib/libbass_fx.so"
+ ;;
+ x86_64)
+ install -D -m755 x64/libbass_fx.so "$pkgdir/usr/lib/libbass_fx.so"
+ ;;
+ armv6h|armv7h)
+ install -D -m755 $CARCH/hardfp/libbass_fx.so "$pkgdir/usr/lib/libbass_fx.so"
+ ;;
+ esac
+
+ install -D -m644 bass_fx.chm "$pkgdir/usr/share/doc/libbass/bass_fx.chm"
+}
diff --git a/bass_fx24-linux.zip b/bass_fx24-linux.zip
new file mode 100644
index 000000000000..6478adf6ce4a
--- /dev/null
+++ b/bass_fx24-linux.zip
Binary files differ
diff --git a/libbass_fx-2.4.11.1-1-x86_64.pkg.tar.xz b/libbass_fx-2.4.11.1-1-x86_64.pkg.tar.xz
new file mode 100644
index 000000000000..b6e68118a602
--- /dev/null
+++ b/libbass_fx-2.4.11.1-1-x86_64.pkg.tar.xz
Binary files differ