summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjfperini2015-06-10 03:56:03 -0300
committerjfperini2015-06-10 03:56:03 -0300
commit2b6502a538a9b5a52d34ad0a99d6149ef078c6a1 (patch)
treee9e49a152f3e62cb380f52d0dbae36b42aff878e
downloadaur-2b6502a538a9b5a52d34ad0a99d6149ef078c6a1.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE83
-rw-r--r--PKGBUILD47
3 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8136db18e9cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libbassenc
+ pkgdesc = An extension that allows BASS channels to be encoded using command-line encoders with STDIN support.
+ pkgver = 2.4.12.8
+ pkgrel = 1
+ url = http://www.un4seen.com/bass.html#addons
+ arch = i686
+ arch = x86_64
+ license = custom:basslicence
+ makedepends = unzip
+ depends = libbass
+ source = http://us.un4seen.com/files/bassenc24-linux.zip
+ source = LICENSE
+ md5sums = a554085402c6d668eabf678f8dec4e24
+ md5sums = 9ba933735ead25f00741f2e6d3abed05
+
+pkgname = libbassenc
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f34386495178
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,83 @@
+Licence
+=======
+BASS is free for non-commercial use. If you are a non-commercial entity
+(eg. an individual) and you are not making any money from your product
+(through sales/advertising/etc), then you can use BASS in it for free.
+If you wish to use BASS in commercial products, then please also see the
+next section.
+
+TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, BASS IS PROVIDED
+"AS IS", WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED,
+INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY
+AND/OR FITNESS FOR A PARTICULAR PURPOSE. THE AUTHORS SHALL NOT BE HELD
+LIABLE FOR ANY DAMAGE THAT MAY RESULT FROM THE USE OF BASS. YOU USE
+BASS ENTIRELY AT YOUR OWN RISK.
+
+Usage of BASS indicates that you agree to the above conditions.
+
+All trademarks and other registered names contained in the BASS
+package are the property of their respective owners.
+
+Commercial licensing
+--------------------
+BASS is available for use in your commercial products. The licence
+types available are as follows:
+
+SHAREWARE: Allows the usage of BASS in an unlimited number of your
+shareware ("try before you buy") products, which must sell for no more
+than 40 Euros each. Non-shareware products are also permitted, but the
+product price limit is 10 Euros in that case. The price limit can be
+raised by purchasing duplicate licences, eg. 2 licences doubles it. If
+you are an individual (not a corporation) making and selling your own
+software, this is the licence for you.
+
+SINGLE COMMERCIAL: Allows the usage of BASS in one commercial product.
+
+UNLIMITED COMMERCIAL: Allows the usage of BASS in an unlimited number
+of your commercial products. This licence is on a per-site basis, eg.
+if you are creating products with BASS at 2 sites/locations, then 2
+licences are required.
+
+Please note the products must be end-user products, eg. not components
+used by other products.
+
+These licences only cover your own software, not the publishing of
+other's software. If you publish other's software, its developers (or
+the software itself) will need to be licensed to use BASS.
+
+These licences are on a per-platform basis, with reductions available
+when licensing for multiple platforms. In all cases there are no royalties
+to pay, and you can use future BASS updates without further cost.
+
+These licences do not allow reselling/sublicensing of BASS. For example,
+if a product is a development system, the users of said product are not
+licensed to use BASS in their productions; they will need their own
+licences.
+
+If the standard licences do not meet your requirements, or if you have
+any questions, please get in touch (email: bass@un4seen.com).
+
+Visit the BASS website for the latest pricing:
+
+ www.un4seen.com
+
+MP3
+---
+MP3 technology is patented, and Thomson license the use of their and
+Fraunhofer's patents. The inclusion of an MP3 decoder (eg. BASS) in a
+commercial product requires an MP3 patent licence. Contact Thomson for
+details:
+
+ www.mp3licensing.com
+
+Alternatively, the "MP3-FREE" BASS version does not include its own MP3
+decoder but instead makes use of the operating system's already licensed
+decoder. If an MP3 decoder is not available, then MP3 playback will not
+be possible, but everything else will function as normal.
+
+NOTE: When using the OS's MP3 decoder, BASS still does the file handling
+ so all the usual features are still supported, including streaming,
+ tag reading, pre-scanning, gapless playback, etc.
+
+NOTE: Linux does not include an MP3 decoder as standard. The "MP3-FREE"
+ BASS version will make use of the libmpg123 decoder, if installed. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e852f04798ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: jfperini <@jfperini>
+# Contributor: jfperini <@jfperini>
+
+pkgname=libbassenc
+pkgver=2.4.12.8
+pkgrel=1
+pkgdesc="An extension that allows BASS channels to be encoded using command-line encoders with STDIN support."
+arch=('i686' 'x86_64')
+url="http://www.un4seen.com/bass.html#addons"
+license=('custom:basslicence')
+depends=('libbass')
+makedepends=('unzip')
+# provides=('')
+# conflicts=('')
+source=('http://us.un4seen.com/files/bassenc24-linux.zip' 'LICENSE')
+md5sums=('a554085402c6d668eabf678f8dec4e24'
+ '9ba933735ead25f00741f2e6d3abed05')
+
+
+package() {
+
+ mkdir -p "$pkgdir/usr/lib/"
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ mkdir -p "$pkgdir/usr/include"
+
+ cp "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+ cp "$srcdir/bassenc.chm" "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 " -> Installing program..."
+
+ [ "$CARCH" == i686 ] && install -Dm755 "$srcdir/$pkgname.so" "$pkgdir/usr/lib/"
+
+ [ "$CARCH" == x86_64 ] && install -Dm755 "$srcdir/x64/$pkgname.so" "$pkgdir/usr/lib/"
+
+ cp "$srcdir/bassenc.h" "$pkgdir/usr/include" # I assume this is where it goes...
+
+ # and just in case...
+
+ chmod -R 755 "$pkgdir/usr/lib/$pkgname.so"
+ chmod -R 644 "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ chmod -R 644 "$pkgdir/usr/share/doc/$pkgname/bassenc.chm"
+ chmod -R 644 "$pkgdir/usr/include/bassenc.h"
+
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file