summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Snowhill2023-05-13 00:34:27 -0700
committerChristopher Snowhill2023-05-13 00:34:27 -0700
commit44342c0ee6c1e5a694b29da3524ae6d4fd2f923c (patch)
treecca903579cea9330544e83b5931950ad107b4c4a
downloadaur-44342c0ee6c1e5a694b29da3524ae6d4fd2f923c.tar.gz
2.4.2.3-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD39
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abac67c53cee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libbassopus
+ pkgdesc = BASS audio library Opus plugin
+ pkgver = 2.4.2.3
+ pkgrel = 1
+ url = https://www.un4seen.com/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = custom
+ depends = alsa-lib
+ depends = libbass
+ source = libbassopus-2.4.2.3.zip::http://www.un4seen.com/files/bassopus24-linux.zip
+ sha256sums = 6b537a534486ea61b76f1aabd52d04c55f46d8cc36c76cf4ddea5a78b24195cb
+
+pkgname = libbassopus
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..331c59080337
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+*.pkg.tar.*
+*.zip
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..312e74e2cc22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer:
+# Contributor: Alexander Sulfrian <asulfrian@zedat.fu-berlin.de>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=libbassopus
+pkgver=2.4.2.3
+pkgrel=1
+pkgdesc='BASS audio library Opus plugin'
+arch=(i686 x86_64 armv6h armv7h aarch64)
+url='https://www.un4seen.com/'
+license=(custom)
+depends=(alsa-lib libbass)
+source=("$pkgname-$pkgver.zip::http://www.un4seen.com/files/bassopus24-linux.zip")
+sha256sums=('6b537a534486ea61b76f1aabd52d04c55f46d8cc36c76cf4ddea5a78b24195cb')
+
+prepare() {
+ grep Lic "$srcdir/bassopus.txt" -A14 > LICENSE
+}
+
+package() {
+ case "$CARCH" in
+ i686)
+ install -D -m644 libs/x86/libbassopus.so "$pkgdir/usr/lib/libbassopus.so"
+ ;;
+ armv6h|armv7h)
+ install -D -m644 libs/armhf/libbassopus.so "$pkgdir/usr/lib/libbassopus.so"
+ ;;
+ aarch64|x86_64)
+ install -D -m644 libs/$CARCH/libbassopus.so "$pkgdir/usr/lib/libbassopus.so"
+ ;;
+ esac
+
+ install -D -m644 bassopus.h "$pkgdir/usr/include/bassopus.h"
+ install -D -m644 bassopus.chm "$pkgdir/usr/share/doc/libbassopus/bassopus.chm"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# getver: -u=2 un4seen.com/bass.html
+# vim: ts=2 sw=2 et: