summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Snowhill2023-05-13 00:35:37 -0700
committerChristopher Snowhill2023-05-13 00:35:37 -0700
commitb906068b1d4babd6750aa4883564a8d6c121e5d9 (patch)
tree1713b95ff71e5929c5dac1a3ddd00296f9f51762
downloadaur-b906068b1d4babd6750aa4883564a8d6c121e5d9.tar.gz
2.4.7.3-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD39
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a970d33d4e6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libbasswv
+ pkgdesc = BASS audio library WavPack plugin
+ pkgver = 2.4.7.3
+ pkgrel = 1
+ url = https://www.un4seen.com/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = custom
+ depends = alsa-lib
+ depends = libbass
+ source = libbasswv-2.4.7.3.zip::http://www.un4seen.com/files/basswv24-linux.zip
+ sha256sums = bdeab6044f87aab2eb5bb0c1b4c17cbeb2f3775988fca657fc4834491d755def
+
+pkgname = libbasswv
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..331c59080337
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+*.pkg.tar.*
+*.zip
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6774387c165
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer:
+# Contributor: Alexander Sulfrian <asulfrian@zedat.fu-berlin.de>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=libbasswv
+pkgver=2.4.7.3
+pkgrel=1
+pkgdesc='BASS audio library WavPack plugin'
+arch=(i686 x86_64 armv6h armv7h aarch64)
+url='https://www.un4seen.com/'
+license=(custom)
+depends=(alsa-lib libbass)
+source=("$pkgname-$pkgver.zip::http://www.un4seen.com/files/basswv24-linux.zip")
+sha256sums=('bdeab6044f87aab2eb5bb0c1b4c17cbeb2f3775988fca657fc4834491d755def')
+
+prepare() {
+ grep Lic "$srcdir/basswv.txt" -A14 > LICENSE
+}
+
+package() {
+ case "$CARCH" in
+ i686)
+ install -D -m644 libs/x86/libbasswv.so "$pkgdir/usr/lib/libbasswv.so"
+ ;;
+ armv6h|armv7h)
+ install -D -m644 libs/armhf/libbasswv.so "$pkgdir/usr/lib/libbasswv.so"
+ ;;
+ aarch64|x86_64)
+ install -D -m644 libs/$CARCH/libbasswv.so "$pkgdir/usr/lib/libbasswv.so"
+ ;;
+ esac
+
+ install -D -m644 basswv.h "$pkgdir/usr/include/basswv.h"
+ install -D -m644 basswv.chm "$pkgdir/usr/share/doc/libbasswv/basswv.chm"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# getver: -u=2 un4seen.com/bass.html
+# vim: ts=2 sw=2 et: