summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 17:25:42 +0200
committersl1pkn072015-06-08 17:25:42 +0200
commit4bc459e2c49bf066a353b5c7a1d2216593096f9d (patch)
tree9491f54dc01b7a613385ef56e77a88b46227751f
downloadaur-4bc459e2c49bf066a353b5c7a1d2216593096f9d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..794fed511a35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libbdplus-git
+ pkgdesc = Open implementation of BD+ protocol. (GIT version)
+ pkgver = 0.1.2.6.gb7aaa91
+ pkgrel = 1
+ url = http://www.videolan.org/developers/libbdplus.html
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = libaacs
+ provides = libbdplus
+ conflicts = libbdplus
+ source = git://git.videolan.org/libbdplus.git
+ sha1sums = SKIP
+
+pkgname = libbdplus-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16e020689249
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=libbdplus-git
+pkgver=0.1.2.6.gb7aaa91
+pkgrel=1
+pkgdesc="Open implementation of BD+ protocol. (GIT version)"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://www.videolan.org/developers/libbdplus.html"
+depends=('libaacs')
+makedepends=('git')
+provides=('libbdplus')
+conflicts=('libbdplus')
+source=('git://git.videolan.org/libbdplus.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd libbdplus
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd libbdplus
+ ./bootstrap
+}
+
+build() {
+ cd libbdplus
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ make -C libbdplus DESTDIR="${pkgdir}" install
+}