summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorC. N. Hsing2019-04-20 14:14:41 +0800
committerC. N. Hsing2019-04-20 14:15:10 +0800
commitbb38f786bf45b78eda158cec475482d310314fce (patch)
treea1b0b9e7e4ee9b9d7908f73fbe022325ab0629e0
downloadaur-bb38f786bf45b78eda158cec475482d310314fce.tar.gz
init
PKGBUILD imported from libbfio-git enable wide-char support
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d6ecd3a4990
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libbfio
+ pkgdesc = Library for providing a basic file input/output abstraction layer
+ pkgver = 20190112
+ pkgrel = 1
+ url = https://github.com/libyal/libbfio
+ arch = x86_64
+ arch = i686
+ license = LGPL
+ depends = glibc
+ provides = libbfio
+ conflicts = libbfio-git
+ source = https://github.com/libyal/libbfio/releases/download/20190112/libbfio-alpha-20190112.tar.gz
+ sha512sums = 3bf8c4fec6a283c6e03cc25e33737b28fc747655b720b44e621b402f6f3181e9b1778555db45ca4d7d10f36996cb7f2e5d379d0cf958c5aae5579cbc0705e310
+
+pkgname = libbfio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fba4e40f4669
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Jaryl Chng <mrciku@gmail.com>
+pkgname=libbfio
+pkgver=20190112
+pkgrel=1
+pkgdesc='Library for providing a basic file input/output abstraction layer'
+arch=('x86_64' 'i686')
+url='https://github.com/libyal/libbfio'
+license=('LGPL')
+provides=('libbfio')
+conflicts=('libbfio-git')
+depends=('glibc')
+source=('https://github.com/libyal/libbfio/releases/download/'$pkgver'/libbfio-alpha-'$pkgver'.tar.gz')
+sha512sums=('3bf8c4fec6a283c6e03cc25e33737b28fc747655b720b44e621b402f6f3181e9b1778555db45ca4d7d10f36996cb7f2e5d379d0cf958c5aae5579cbc0705e310')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-wide-character-type=yes
+}
+
+build() {
+ make -C "$srcdir/$pkgname-$pkgver"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}