summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 19:47:03 +0200
committerDaniel Nagy2015-06-08 19:47:03 +0200
commit896ff66ec00e0d5863112ba3c575f1401145d9ea (patch)
treeb5bd03bac8f1aae94b4596d67691505f60cebd09
downloadaur-896ff66ec00e0d5863112ba3c575f1401145d9ea.tar.gz
import to aur4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e133c5a11e92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libbitcoin
+ pkgdesc = asynchronous C++ library for Bitcoin
+ pkgver = 2.8.0
+ pkgrel = 3
+ url = https://github.com/libbitcoin/libbitcoin/
+ arch = i686
+ arch = x86_64
+ license = AGPL
+ depends = boost
+ depends = openssl
+ depends = curl
+ depends = icu
+ depends = secp256k1-git
+ source = libbitcoin-2.8.0.tar.gz::https://github.com/libbitcoin/libbitcoin/archive/v2.8.0.tar.gz
+ sha256sums = 47753bc3723d89e2ff4856a481429cdffd8a13f6870f66a495d5a6db4239d191
+
+pkgname = libbitcoin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4b30026af07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+pkgname=libbitcoin
+pkgver=2.8.0
+pkgrel=3
+pkgdesc="asynchronous C++ library for Bitcoin"
+arch=('i686' 'x86_64')
+url="https://github.com/libbitcoin/libbitcoin/"
+license=('AGPL')
+depends=('boost' 'openssl' 'curl' 'icu')
+# currently we need the git version of this library because the non-git version
+# does not package the pkg-config file which this package expects
+depends+=('secp256k1-git')
+makedepends=()
+source=( "$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz" )
+sha256sums=('47753bc3723d89e2ff4856a481429cdffd8a13f6870f66a495d5a6db4239d191')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ autoreconf -i
+ ./configure --prefix="/usr/" --with-icu
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}