summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commit3133c0dfacf4bcd09f731acebd69259f64c43086 (patch)
tree15e9695166ed7ace5ca943272b79612cc3f5cc8d
downloadaur-3133c0dfacf4bcd09f731acebd69259f64c43086.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD62
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92951c9a0271
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = libbitcoin-blockchain-git
+ pkgdesc = Bitcoin Blockchain Implementation
+ pkgver = 20150519
+ pkgrel = 1
+ url = https://github.com/libbitcoin/libbitcoin-blockchain
+ arch = i686
+ arch = x86_64
+ groups = libbitcoin
+ license = AGPL3
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = gcc
+ makedepends = git
+ makedepends = libtool
+ makedepends = make
+ makedepends = pkg-config
+ depends = boost
+ depends = boost-libs
+ depends = libbitcoin-git
+ depends = secp256k1-git
+ provides = libbitcoin-blockchain
+ conflicts = libbitcoin-blockchain
+ source = git+https://github.com/libbitcoin/libbitcoin-blockchain
+ sha256sums = SKIP
+
+pkgname = libbitcoin-blockchain-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c4913084fa5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=libbitcoin-blockchain-git
+pkgver=20150519
+pkgrel=1
+pkgdesc="Bitcoin Blockchain Implementation"
+arch=('i686' 'x86_64')
+depends=('boost'
+ 'boost-libs'
+ 'libbitcoin-git'
+ 'secp256k1-git')
+makedepends=('autoconf'
+ 'automake'
+ 'gcc'
+ 'git'
+ 'libtool'
+ 'make'
+ 'pkg-config')
+groups=('libbitcoin')
+url="https://github.com/libbitcoin/libbitcoin-blockchain"
+license=('AGPL3')
+source=(git+https://github.com/libbitcoin/libbitcoin-blockchain)
+sha256sums=('SKIP')
+provides=('libbitcoin-blockchain')
+conflicts=('libbitcoin-blockchain')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+build() {
+ cd ${pkgname%-git}
+
+ msg2 'Building...'
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/libbitcoin-blockchain \
+ --sysconfdir=/etc \
+ --sharedstatedir=/usr/share/libbitcoin-blockchain \
+ --localstatedir=/var/lib/libbitcoin-blockchain \
+ --with-gnu-ld \
+ --without-tests \
+ --without-tools
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg2 'Installing license...'
+ install -Dm 644 COPYING "$pkgdir/usr/share/licenses/libbitcoin-blockchain/COPYING"
+
+ msg2 'Installing...'
+ make DESTDIR="$pkgdir" install
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}