summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-06-07 15:43:32 -0700
committerAndy Weidenbaum2017-06-07 15:43:32 -0700
commit633ffeb9f6a70dba9b4a49422ee70ca24305326e (patch)
tree05ebeb72e306e26b04bc42f14dc3d047ae8b7fc7
parent99cbdaa04a3ca58ff3b9fae8296d8490a105bde6 (diff)
downloadaur-633ffeb9f6a70dba9b4a49422ee70ca24305326e.tar.gz
increment pkgrel; fix make -j for nproc=1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c860ce210909..3935a2b5360f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Mar 8 20:26:51 UTC 2017
+# Wed Jun 7 22:36:19 UTC 2017
pkgbase = libbitcoin-blockchain-git
pkgdesc = Bitcoin Blockchain Library
pkgver = 20170228
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/libbitcoin/libbitcoin-blockchain
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index ec792027ec91..c909dbdcd7f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libbitcoin-blockchain-git
pkgver=20170228
-pkgrel=2
+pkgrel=3
pkgdesc="Bitcoin Blockchain Library"
arch=('i686' 'x86_64')
depends=('boost'
@@ -28,6 +28,10 @@ sha256sums=('SKIP')
provides=('libbitcoin-blockchain')
conflicts=('libbitcoin-blockchain')
+# half of available processing units or one if only one is available
+_nproc=$(($(nproc)/2))
+[[ ${_nproc} < 1 ]] && _nproc=1
+
pkgver() {
cd ${pkgname%-git}
git log -1 --format="%cd" --date=short | sed "s|-||g"
@@ -46,21 +50,14 @@ build() {
--sharedstatedir=/usr/share/libbitcoin-blockchain \
--localstatedir=/var/lib/libbitcoin-blockchain \
--with-gnu-ld
- make -j$(($(nproc)/2))
-}
-
-check() {
- cd ${pkgname%-git}
-
- msg2 'Testing...'
- make -j$(($(nproc)/2)) check
+ make -j$_nproc
}
check() {
cd ${pkgname%-git}
msg2 'Testing...'
- make -j$(($(nproc)/2)) check
+ make -j$_nproc check
}
package() {