summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-03-08 12:27:08 -0800
committerAndy Weidenbaum2017-03-08 12:27:08 -0800
commit1d758c89f430e3327c63099a66f832e8208bea17 (patch)
tree259b48d888f3edfd4fec148e02a90960d4a6a846
parent3fdf179d60dd20527a6142d401643477b56a8560 (diff)
downloadaur-1d758c89f430e3327c63099a66f832e8208bea17.tar.gz
increment pkgrel to 2; run tests
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bac4a7038325..ee75be123752 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Mar 8 17:45:40 UTC 2017
+# Wed Mar 8 20:26:49 UTC 2017
pkgbase = libbitcoin-client-git
pkgdesc = Bitcoin Client Protocol Library
pkgver = 20170306
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/libbitcoin/libbitcoin-client
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 988df16c8a65..0da139ef93f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libbitcoin-client-git
pkgver=20170306
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin Client Protocol Library"
arch=('i686' 'x86_64')
depends=('boost'
@@ -46,11 +46,17 @@ build() {
--sharedstatedir=/usr/share/libbitcoin-client \
--localstatedir=/var/lib/libbitcoin-client \
--with-gnu-ld \
- --without-examples \
- --without-tests
+ --without-examples
make -j$(($(nproc)/2))
}
+check() {
+ cd ${pkgname%-git}
+
+ msg2 'Testing...'
+ make -j$(($(nproc)/2)) check
+}
+
package() {
cd ${pkgname%-git}