summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-06-07 15:43:32 -0700
committerAndy Weidenbaum2017-06-07 15:43:32 -0700
commite3e751cd0b95118fd66d30e4b806a254e9aa3225 (patch)
treeda2a4462518eca45567a19edc16ee2c4923bcef0
parent431d08058433f8ee0100a2ed09dd637a57d45750 (diff)
downloadaur-e3e751cd0b95118fd66d30e4b806a254e9aa3225.tar.gz
increment pkgrel; fix make -j for nproc=1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 043135f36445..18064b33d89b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue May 2 15:53:04 UTC 2017
+# Wed Jun 7 22:36:19 UTC 2017
pkgbase = libbitcoin-network
pkgdesc = Bitcoin P2P Network Library
pkgver = 3.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/libbitcoin/libbitcoin-network
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 14b3b9c73ef9..0c643fba255c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=libbitcoin-network
pkgver=3.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin P2P Network Library"
arch=('i686' 'x86_64')
depends=('boost'
@@ -27,6 +27,10 @@ sha256sums=('a3e8229ae532803b0ed11fd4b2d3d2df93bcf371eb5108a3c95f3994b501d266')
provides=('libbitcoin-network')
conflicts=('libbitcoin-network')
+# half of available processing units or one if only one is available
+_nproc=$(($(nproc)/2))
+[[ ${_nproc} < 1 ]] && _nproc=1
+
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -40,14 +44,14 @@ build() {
--sharedstatedir=/usr/share/libbitcoin-network \
--localstatedir=/var/lib/libbitcoin-network \
--with-gnu-ld
- make -j$(($(nproc)/2))
+ make -j$_nproc
}
check() {
cd "$srcdir/$pkgname-$pkgver"
msg2 'Testing...'
- make -j$(($(nproc)/2)) check
+ make -j$_nproc check
}
package() {