summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Biereigel2023-05-01 18:46:32 +0200
committerStefan Biereigel2023-05-01 18:46:32 +0200
commita81990c105c40f58d591214f43bd35234544093b (patch)
tree6a123e66d572a53e502dec69a7bd1f843d45456b
parentf8b860df2c0950d2ddbc42f10c6e9b7324e81929 (diff)
downloadaur-libbladerf-git.tar.gz
apply fix for FS#54105
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
2 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0623ba35e0f..cf488499311f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = libbladerf-git
pkgdesc = Driver and userspace for the bladeRF SDR.
- pkgver = 2018.12.rc3.r3.g3bb8ad61
+ pkgver = 2023.02.r33.g2b90ed39
pkgrel = 1
url = https://github.com/Nuand/bladeRF
arch = i686
arch = x86_64
+ arch = aarch64
license = GPL2
makedepends = cmake
makedepends = help2man
@@ -13,7 +14,16 @@ pkgbase = libbladerf-git
provides = bladerf
conflicts = bladerf
source = git+https://github.com/Nuand/bladeRF
+ source = https://www.nuand.com/fpga/hostedxA4-latest.rbf
+ source = https://www.nuand.com/fpga/hostedxA9-latest.rbf
+ source = https://www.nuand.com/fpga/hostedx40-latest.rbf
+ source = https://www.nuand.com/fpga/hostedx115-latest.rbf
+ source = https://www.nuand.com/fx3/bladeRF_fw_latest.img
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = libbladerf-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bdbccce2ceea..7998e76239c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Stefan Biereigel <stefan@biereigel.de>
pkgname=libbladerf-git
-pkgver=2018.12.rc3.r3.g3bb8ad61
+pkgver=2023.02.r33.g2b90ed39
pkgrel=1
pkgdesc="Driver and userspace for the bladeRF SDR."
url="https://github.com/Nuand/bladeRF"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64')
license=('GPL2')
depends=('libusb')
provides=('bladerf')
@@ -47,7 +47,8 @@ build() {
-DBUILD_DOCUMENTATION=ON \
-DCMAKE_INSTALL_LIBDIR:PATH=lib \
-Dusb_LIBRARY:FILEPATH=/usr/lib/libusb-1.0.so \
- -DCMAKE_INSTALL_PREFIX=/usr ../
+ -DCMAKE_INSTALL_PREFIX=/usr ../ \
+ -DUDEV_RULES_PATH=/usr/lib/udev/rules.d
make
# ENABLE_FX3_BUILD needs cypress toolchain
# really really wants to put files in /usr/lib64
@@ -63,4 +64,10 @@ package() {
install -Dm644 hostedxA9-latest.rbf "$pkgdir/usr/share/Nuand/bladeRF/hostedxA9.rbf"
install -Dm644 hostedx40-latest.rbf "$pkgdir/usr/share/Nuand/bladeRF/hostedx40.rbf"
install -Dm644 hostedx115-latest.rbf "$pkgdir/usr/share/Nuand/bladeRF/hostedx115.rbf"
+
+ # FS#54105
+ cd "$pkgdir/usr/lib/udev/rules.d/"
+ mv 88-nuand-bladerf1.rules 70-nuand-bladerf1.rules
+ mv 88-nuand-bladerf2.rules 70-nuand-bladerf2.rules
+ mv 88-nuand-bootloader.rules 70-nuand-bootloader.rules
}