summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2017-04-05 16:19:36 -0700
committerMichael Hansen2017-04-05 16:19:36 -0700
commit7153daaaed48924c98645a54ca9aaa2a5bb750de (patch)
tree50ca4ccfdcac0829cbef78c98b27a2875fffb4f4
downloadaur-7153daaaed48924c98645a54ca9aaa2a5bb750de.tar.gz
Initial import of Debian's libblocksruntime
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD29
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e860301582d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Apr 5 23:15:53 UTC 2017
+pkgbase = libblocksruntime
+ pkgdesc = compiler-rt Blocks runtime library for Clang
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://compiler-rt.llvm.org
+ arch = i686
+ arch = x86_64
+ license = custom:University of Illinois
+ license = MIT
+ depends = clang
+ source = http://http.debian.net/debian/pool/main/libb/libblocksruntime/libblocksruntime_0.4.1.orig.tar.gz
+ sha256sums = 7807e18d7d6cabd90f77c8b8a8ebd472516fa4ed6a02df82e0c33b1c5e112abc
+
+pkgname = libblocksruntime
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4afa7d5e656
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src/
+/pkg/
+*.orig.tar.gz
+*.pkg.tar.xz
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af2933ba0e8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Michael Hansen <zrax0111 gmail com>
+
+pkgname=libblocksruntime
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="compiler-rt Blocks runtime library for Clang"
+arch=("i686" "x86_64")
+url="https://compiler-rt.llvm.org"
+license=("custom:University of Illinois" "MIT")
+depends=("clang")
+source=("http://http.debian.net/debian/pool/main/libb/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz")
+sha256sums=("7807e18d7d6cabd90f77c8b8a8ebd472516fa4ed6a02df82e0c33b1c5e112abc")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make test
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make install DESTDIR="${pkgdir}"
+}