summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 17:26:13 +0200
committersl1pkn072015-06-08 17:26:13 +0200
commitb0a0aa6ce89f2be2df13dc0051a6cd9180073e72 (patch)
treeb8b0f360766d7a3ad79efc9f02151e1597ef4a20
downloadaur-b0a0aa6ce89f2be2df13dc0051a6cd9180073e72.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5999646e4da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = libbluray-git
+ pkgdesc = Library to access Blu-Ray disks for video playback. (GIT version)
+ pkgver = 0.8.0.47.g7b9e926
+ pkgrel = 1
+ url = http://www.videolan.org/developers/libbluray.html
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ makedepends = apache-ant
+ makedepends = libaacs
+ depends = libxml2
+ depends = java-environment
+ depends = fontconfig
+ optdepends = libaacs: Enable AACS decryption
+ provides = libbluray
+ conflicts = libbluray
+ source = git+http://git.videolan.org/git/libbluray.git
+ source = git://git.videolan.org/libudfread.git
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = libbluray-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6f37c4c7885
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=libbluray-git
+pkgver=0.8.0.47.g7b9e926
+pkgrel=1
+pkgdesc="Library to access Blu-Ray disks for video playback. (GIT version)"
+arch=('i686' 'x86_64')
+license=('LGPL2.1')
+url="http://www.videolan.org/developers/libbluray.html"
+depends=('libxml2' "java-environment" 'fontconfig')
+makedepends=('git' 'apache-ant' 'libaacs')
+optdepends=('libaacs: Enable AACS decryption')
+provides=('libbluray')
+conflicts=('libbluray')
+source=('git+http://git.videolan.org/git/libbluray.git'
+ 'git://git.videolan.org/libudfread.git')
+sha1sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd libbluray
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd libbluray
+ git submodule init
+ git config submodule.contrib/libudfread.url "file://${srcdir}/libudfread"
+ git submodule update
+ ./bootstrap
+}
+
+build() {
+ cd libbluray
+ JDK_HOME="/usr/lib/jvm/default" ./configure --prefix=/usr --disable-static --enable-udf
+ make
+}
+
+package() {
+ make -C libbluray DESTDIR="${pkgdir}" install
+}