summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Bacircea2019-12-21 15:05:39 +0200
committerAdrian Bacircea2019-12-21 15:05:39 +0200
commitaf8da5a59d52fbb7b38f6d1367bee76ac16251cf (patch)
treeb0c4defdd58375199caa54198f8e7b2715bee913
parent3f21e8b5bdc9d0c61138d5bcb60582899498b714 (diff)
downloadaur-af8da5a59d52fbb7b38f6d1367bee76ac16251cf.tar.gz
Track master
Add linux-api-headers dependency with version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd10064f67b2..cf4ce81d6a98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = libbpf-git
pkgdesc = BPF library
- pkgver = 0.0.6
+ pkgver = 0.0.6.r41.e7a82fc
pkgrel = 1
url = https://github.com/libbpf/libbpf
arch = x86_64
license = custom
makedepends = rsync
depends = libelf
+ depends = linux-api-headers>=5.4
provides = libbpf
- source = git+https://github.com/libbpf/libbpf#tag=v0.0.6
+ conflicts = libbpf
+ source = git+https://github.com/libbpf/libbpf
sha256sums = SKIP
pkgname = libbpf-git
diff --git a/PKGBUILD b/PKGBUILD
index 006b7a691920..7398b71683ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
# Maintainer: Adrian Bacircea <adrian.bacircea@gmail.com>
pkgname=libbpf-git
-pkgver=0.0.6
+pkgver=0.0.6.r41.e7a82fc
pkgrel=1
pkgdesc='BPF library'
-depends=('libelf')
+depends=('libelf' 'linux-api-headers>=5.4')
url='https://github.com/libbpf/libbpf'
license=('custom')
makedepends=('rsync')
arch=('x86_64')
provides=('libbpf')
-source=('git+https://github.com/libbpf/libbpf#tag=v0.0.6')
+conflicts=('libbpf')
+source=("git+https://github.com/libbpf/libbpf")
sha256sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}/src"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//g')"
+}
+
build() {
cd "${srcdir}/${pkgname%-git}/src"
make