summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan PONIN2015-06-11 03:25:27 +0200
committerJohan PONIN2015-06-11 03:25:27 +0200
commit6edb7a33f233161bd089c582af6dafb26ab0bb3a (patch)
tree1cfafcde658fb12ad71f7c9d5a2dac33ba3e61d0
downloadaur-6edb7a33f233161bd089c582af6dafb26ab0bb3a.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b382f5f64b3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.0
+# Mon Jan 12 03:47:09 UTC 2015
+pkgbase = libbpg
+ pkgdesc = BPG Image Encoder and Decoder
+ pkgver = 0.9.5
+ pkgrel = 1
+ url = http://bellard.org/bpg/
+ arch = x86_64
+ arch = i686
+ license = BSD
+ license = LGPL
+ depends = libpng
+ depends = libjpeg-turbo
+ depends = x265
+ depends = sdl_image
+ options = staticlibs
+ source = http://bellard.org/bpg/libbpg-0.9.5.tar.gz
+ md5sums = 30d1619656955fb3fbba5fe9f9f27f67
+
+pkgname = libbpg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04823db685e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Johan PONIN <johan.ponin.pro at gmail dot com>
+# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Mike Swanson <mikeonthecomputer@gmail.com>
+
+pkgname=libbpg
+pkgver=0.9.5
+pkgrel=1
+pkgdesc='BPG Image Encoder and Decoder'
+arch=('x86_64' 'i686')
+url='http://bellard.org/bpg/'
+license=('BSD' 'LGPL')
+depends=('libpng' 'libjpeg-turbo' 'x265' 'sdl_image')
+source=("$url$pkgname-$pkgver.tar.gz")
+options=('staticlibs')
+
+build() {
+ make USE_X265=Y -C "$pkgname-$pkgver"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 bpgdec "$pkgdir/usr/bin/bpgdec"
+ install -Dm755 bpgenc "$pkgdir/usr/bin/bpgenc"
+ install -Dm755 bpgview "$pkgdir/usr/bin/bpgview"
+ install -Dm644 libbpg.a "$pkgdir/usr/lib/libbpg.a"
+ install -Dm644 libbpg.h "$pkgdir/usr/include/libbpg.h"
+ install -Dm644 bpgenc.h "$pkgdir/usr/include/bpgenc.h"
+}
+
+# vim:set ts=2 sw=2 et:
+
+md5sums=('30d1619656955fb3fbba5fe9f9f27f67')