summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2015-07-04 16:42:04 +0200
committergraziano.giuliani2015-07-04 16:42:04 +0200
commit1ab8c66f7191b4facb711792f3aa46db269b5537 (patch)
tree52a657e65456a29072a620fcf418c9ecfa5df3e0
downloadaur-1ab8c66f7191b4facb711792f3aa46db269b5537.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD56
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0f3c808b2be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libbufr
+ pkgdesc = NCEP library to encode or decode BUFR messages
+ pkgver = 11.0.0
+ pkgrel = 1
+ url = http://www.nco.ncep.noaa.gov/sib/decoders/BUFRLIB/
+ arch = i686
+ arch = x86_64
+ license = Custom
+ makedepends = gcc-fortran
+ options = staticlibs
+ source = http://www.nco.ncep.noaa.gov/sib/decoders/BUFRLIB/BUFRLIB_v11-0-0.tar
+ source = LICENSE
+ md5sums = 885d691ab923a140aa23cc4b0b2fb6a7
+ md5sums = f9f43492185682b834428d79f718f28e
+
+pkgname = libbufr
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..31d3b9bf0bb9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+The software on NWS government servers are in the public domain,
+unless specifically annotated otherwise, and may be used freely by the
+public so long as you do not
+
+ 1) claim it is your own (e.g. by claiming copyright for NWS information
+ 2) use it in a manner that implies an endorsement or affiliation with
+ NOAA/NWS
+ 3) modify it in content and then present it as official government material.
+
+You also cannot present information of your own in a way that makes it appear to
+be official government information.
+
+As required by 17 U.S.C. 403, third parties producing copyrighted works
+consisting predominantly of the material appearing in NWS Web pages must
+provide notice with such work(s) identifying the NWS material incorporated
+and stating that such material is not subject to copyright protection.
+
+The user assumes the entire risk related to its use of this software. NWS is
+providing this software "as is," and NWS disclaims any and all warranties,
+whether express or implied, including (without limitation) any implied
+warranties of merchantability or fitness for a particular purpose.
+In no event will NWS be liable to you or to any third party for any direct,
+indirect, incidental, consequential, special or exemplary damages or lost
+profit resulting from any use or misuse of this software.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..569b2e3f3f66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Graziano Giuliani <graziano.giuliani@gmail.com>
+pkgname=libbufr
+pkgver=11.0.0
+pkgrel=1
+pkgdesc="NCEP library to encode or decode BUFR messages"
+arch=(i686 x86_64)
+url="http://www.nco.ncep.noaa.gov/sib/decoders/BUFRLIB/"
+license=('Custom')
+options=('staticlibs')
+makedepends=(gcc-fortran)
+source=('http://www.nco.ncep.noaa.gov/sib/decoders/BUFRLIB/BUFRLIB_v11-0-0.tar'
+ 'LICENSE')
+md5sums=('885d691ab923a140aa23cc4b0b2fb6a7'
+ 'f9f43492185682b834428d79f718f28e')
+
+build() {
+ cd ${srcdir}
+ export CC=gcc
+ export FC=gfortran
+ export BFRCFLAGS="-DDYNAMIC_ALLOCATION -DNFILES=32 \
+ -DMAXCD=250 -DMAXNC=600 -DMXNAF=3"
+ export BFRFFLAGS="-DLITTLE_ENDIAN -DNORMAL_BUILD -DDYNAMIC_ALLOCATION"
+ export FCFLAGS="${CFLAGS} -fdollar-ok"
+ export AR=ar
+ export ARFLAGS=-rv
+ sed -i bufrlib.PRM -e 's/ / /g'
+ cpp -P -DNORMAL_BUILD -DDYNAMIC_ALLOCATION bufrlib.PRM bufrlib.prm
+ for file in *.c
+ do
+ echo "compiling $file"
+ ${CC} ${CFLAGS} ${BFRCFLAGS} -c -DUNDERSCORE $file
+ done
+ for file in modv* moda*
+ do
+ echo "compiling $file"
+ ${FC} ${FCFLAGS} ${BFRFFLAGS} -c $file
+ done
+ for file in `ls -1 *.F *.f | grep -v mod[av]`
+ do
+ echo "compiling $file"
+ ${FC} ${FCFLAGS} ${BFRFFLAGS} -c $file
+ done
+ ${AR} ${ARFLAGS} libncepbufr.a *.o
+}
+
+package() {
+ cd ${srcdir}
+ mkdir -p ${pkgdir}/usr/lib
+ mkdir -p ${pkgdir}/usr/include
+ mkdir -p ${pkgdir}/usr/share/licenses/libbufr
+ install -m 644 libncepbufr.a ${pkgdir}/usr/lib
+ install -m 644 bufrlib.h ${pkgdir}/usr/include
+ install -m 644 LICENSE ${pkgdir}/usr/share/licenses/libbufr
+}
+
+# vim:set ts=2 sw=2 et: