summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvy Foster2015-12-11 17:33:04 -0600
committerIvy Foster2015-12-11 17:33:04 -0600
commit33a4de333c3fb2def26d4f27ca4d74139c47389d (patch)
tree4ce91795cffb456a8062451b33a8fc51016d63cb
downloadaur-33a4de333c3fb2def26d4f27ca4d74139c47389d.tar.gz
Initial commit: libbulletml-0.0.6-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD53
-rw-r--r--libbulletml.changelog3
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b1c3ab43563
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libbulletml
+ pkgdesc = C++ library to handle BulletML, a markup language to describe bullets in shooting games.
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = http://shinh.skr.jp/libbulletml/index_en.html
+ changelog = libbulletml.changelog
+ arch = x86_64
+ arch = i686
+ license = custom:libbulletml
+ noextract = d_cpp.tar.bz2
+ source = http://shinh.skr.jp/libbulletml/libbulletml-0.0.6.tar.bz2
+ source = http://shinh.skr.jp/d/d_cpp.tar.bz2
+ source = http://http.debian.net/debian/pool/main/b/bulletml/bulletml_0.0.6-5.debian.tar.bz2
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = f6ef24ea2dd1d572bee08207176d150b3a52b7075e4da9a05af3376fd8cbb672
+
+pkgname = libbulletml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64b62cbdf134
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: Ivy Foster <ivy.foster@gmail.com>
+# Reference: PKGBUILD(5)
+
+pkgname=libbulletml
+pkgver=0.0.6
+pkgrel=1
+pkgdesc='C++ library to handle BulletML, a markup language to describe bullets in shooting games.'
+url='http://shinh.skr.jp/libbulletml/index_en.html'
+license=('custom:libbulletml')
+changelog='libbulletml.changelog'
+
+arch=('x86_64' 'i686')
+source=("http://shinh.skr.jp/libbulletml/libbulletml-$pkgver.tar.bz2"
+ 'http://shinh.skr.jp/d/d_cpp.tar.bz2'
+ "http://http.debian.net/debian/pool/main/b/bulletml/bulletml_$pkgver-5.debian.tar.bz2")
+# upstream does not provide checksums, though Debian does for their patches
+sha256sums=('SKIP' 'SKIP'
+ 'f6ef24ea2dd1d572bee08207176d150b3a52b7075e4da9a05af3376fd8cbb672')
+noextract=('d_cpp.tar.bz2')
+
+prepare() {
+ cd bulletml
+ tar xf "$srcdir"/d_cpp.tar.bz2
+ for patch in "$srcdir"/debian/patches/*.patch; do
+ patch -Np1 < "$patch"
+ done
+}
+
+build() {
+ cd bulletml
+ make -C src libbulletml.a
+ rm -f src/*.o src/*/*.o # yes, really, this actually *is* necessary
+ make -C src CFLAGS="$CFLAGS -fPIC -fpic" CXXFLAGS="$CFLAGS -fPIC -fpic" \
+ LDFLAGS="-Wl,-z,defs" libbulletml.so
+}
+
+package() {
+ cd bulletml
+
+ install -D -m 644 src/bulletml.d "$pkgdir"/usr/include/d/bulletml.d
+ install -d "$pkgdir"/usr/include/bulletml/tinyxml
+ install -m 644 src/*.h "$pkgdir"/usr/include/bulletml
+ install -m 644 src/tinyxml/tinyxml.h "$pkgdir"/usr/include/bulletml/tinyxml
+
+ install -d "$pkgdir"/usr/lib
+ install -m 644 src/libbulletml.{a,so} "$pkgdir"/usr/lib
+
+ install -D -m 644 README "$pkgdir"/usr/share/doc/libbulletml/README.jp
+ install -m 644 README.en "$pkgdir"/usr/share/doc/libbulletml
+ install -m 644 README.bulletml "$pkgdir"/usr/share/doc/libbulletml
+ install -D -m 644 README "$pkgdir"/usr/share/licenses/libbulletml/README.jp
+ install -m 644 README.en "$pkgdir"/usr/share/licenses/libbulletml
+}
diff --git a/libbulletml.changelog b/libbulletml.changelog
new file mode 100644
index 000000000000..271d90e64932
--- /dev/null
+++ b/libbulletml.changelog
@@ -0,0 +1,3 @@
+2015-12-11 Ivy Foster <ivy.foster@gmail.com>
+ * 0.0.6-1:
+ - Initial commit