summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvy Foster2018-02-01 17:23:37 -0600
committerIvy Foster2018-02-01 17:23:37 -0600
commit70e94f25401084f3d7fb2bc54f616c8c756c00bb (patch)
tree4720f55271b39fe1aca1a98925285e6251369252
parent7060dc48ce5675e93913ef5874a842bdc243b2e3 (diff)
downloadaur-70e94f25401084f3d7fb2bc54f616c8c756c00bb.tar.gz
Further clean up Makefile
-rw-r--r--.SRCINFO22
-rw-r--r--Makefile5
-rw-r--r--PKGBUILD4
3 files changed, 5 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c56e00bb7abb..7d230ff2c149 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,7 @@
pkgbase = libbulletml
pkgdesc = C++ library to handle BulletML, a markup language to describe bullets in shooting games.
pkgver = 0.0.6
- pkgrel = 2
- url = http://shinh.skr.jp/libbulletml/index_en.html
- arch = x86_64
- arch = i686
- license = custom:libbulletml
- noextract = d_cpp.tar.bz2
- source = http://shinh.skr.jp/libbulletml/libbulletml-0.0.6.tar.bz2
- source = http://shinh.skr.jp/d/d_cpp.tar.bz2
- source = http://http.debian.net/debian/pool/main/b/bulletml/bulletml_0.0.6-5.debian.tar.bz2
- sha256sums = 7c37f3d2d52825417c5de716f89bea4b71156371e698e2579daf7921df07aa79
- sha256sums = f0a9f01ef9daaa980f876253c81e8e76eea17b7de1aa569bf23661b456c5c9d3
- sha256sums = f6ef24ea2dd1d572bee08207176d150b3a52b7075e4da9a05af3376fd8cbb672
-
-pkgname = libbulletml
-
-pkgbase = libbulletml
- pkgdesc = C++ library to handle BulletML, a markup language to describe bullets in shooting games.
- pkgver = 0.0.6
- pkgrel = 3
+ pkgrel = 4
url = http://shinh.skr.jp/libbulletml/index_en.html
arch = x86_64
arch = i686
@@ -32,7 +14,7 @@ pkgbase = libbulletml
sha256sums = 7c37f3d2d52825417c5de716f89bea4b71156371e698e2579daf7921df07aa79
sha256sums = f0a9f01ef9daaa980f876253c81e8e76eea17b7de1aa569bf23661b456c5c9d3
sha256sums = e85182a82604b4bc3c3f42b35f5d77decd327239602bcc4b5ac3a2e1269f211e
- sha256sums = 0d04bf79f0c9ae834a2520190507d5b1bf8e1f501a0ef5fadcee9575eb2c8bf2
+ sha256sums = ce5f9d510b81f6a7141408ca2c3c80d86dc7d371098696965d752381b7fdeba9
pkgname = libbulletml
diff --git a/Makefile b/Makefile
index f725d6e51127..2de5f08a1314 100644
--- a/Makefile
+++ b/Makefile
@@ -29,16 +29,13 @@ libbulletml.so.$(MAJOR).$(MINOR): $(OBJS) $(TINYXML)
bulletml.d: bulletml_d.cpp
perl ../d_cpp/create_d_import.pl bulletml_d.cpp bulletml.d
-$(TINYXML): %.o: %.cpp
- $(CXX) -c $(CXXFLAGS) -fPIC -fpic $(INCLUDES) $< -o $@
-
clean:
rm -f calc.cpp libbulletml.a libbulletml.so.$(MAJOR).$(MINOR) *.o tinyxml/*.o
calc.cpp: calc.yy
bison -y calc.yy -o calc.cpp
-$(OBJS): %.o: %.cpp
+$(OBJS) $(TINYXML): %.o: %.cpp
$(CXX) -c $(CXXFLAGS) -fPIC -fpic $(INCLUDES) $<
doxy:
diff --git a/PKGBUILD b/PKGBUILD
index 3e229b693cfb..63502676799a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=libbulletml
pkgver=0.0.6
-pkgrel=3
+pkgrel=4
pkgdesc='C++ library to handle BulletML, a markup language to describe bullets in shooting games.'
url='http://shinh.skr.jp/libbulletml/index_en.html'
license=('custom:libbulletml')
@@ -21,7 +21,7 @@ sha256sums=(
7c37f3d2d52825417c5de716f89bea4b71156371e698e2579daf7921df07aa79
f0a9f01ef9daaa980f876253c81e8e76eea17b7de1aa569bf23661b456c5c9d3
e85182a82604b4bc3c3f42b35f5d77decd327239602bcc4b5ac3a2e1269f211e
- 0d04bf79f0c9ae834a2520190507d5b1bf8e1f501a0ef5fadcee9575eb2c8bf2
+ ce5f9d510b81f6a7141408ca2c3c80d86dc7d371098696965d752381b7fdeba9
)
noextract=(d_cpp.tar.bz2)