summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-06-04 01:05:43 +0800
committerChocobo12021-06-04 01:08:59 +0800
commit486700110d3fd7a3678d412beba2ecdfa3596828 (patch)
tree4e880abcd1103a6bb051191d6e494edf7b1d2864
downloadaur-486700110d3fd7a3678d412beba2ecdfa3596828.tar.gz
newpkg: libburn-git 1.5.4.r5.g892df64-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4428cedb31b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libburn-git
+ pkgdesc = Library for reading, mastering and writing optical discs
+ pkgver = 1.5.4.r5.g892df64
+ pkgrel = 1
+ url = https://dev.lovelyhq.com/libburnia/web/wiki/Libburn
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glibc
+ provides = libburn
+ conflicts = libburn
+ options = staticlibs
+ source = git+https://dev.lovelyhq.com/libburnia/libburn.git
+ sha256sums = SKIP
+
+pkgname = libburn-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47dff517ae71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libburn-git
+pkgver=1.5.4.r5.g892df64
+pkgrel=1
+pkgdesc="Library for reading, mastering and writing optical discs"
+arch=('i686' 'x86_64')
+url="https://dev.lovelyhq.com/libburnia/web/wiki/Libburn"
+license=('GPL')
+depends=('glibc')
+makedepends=('git')
+provides=('libburn')
+conflicts=('libburn')
+options=('staticlibs')
+source=("git+https://dev.lovelyhq.com/libburnia/libburn.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libburn"
+
+ git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libburn"
+
+ ./bootstrap
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libburn"
+
+ make check
+}
+
+package() {
+ cd "libburn"
+
+ make DESTDIR="$pkgdir" install
+}