summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 19:46:47 +0200
committerDaniel Nagy2015-06-08 19:46:47 +0200
commit0e3b7815dfc2c00a2656ac8a07e71e477ea0c070 (patch)
tree040feb9eff38f88445229d2ea60b708d59f51ee2
downloadaur-0e3b7815dfc2c00a2656ac8a07e71e477ea0c070.tar.gz
import to aur4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e81f8361b586
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libbuspirate
+ pkgdesc = The libbuspirate is a C library to talk with the bus pirate hardware
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://sourceforge.net/projects/libbuspirate/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = GPLv3
+ source = http://downloads.sourceforge.net/project/libbuspirate/0.4.0/libbuspirate-0.4.0.tar.gz
+ sha1sums = fbbfdddec5ef46870463d654bb2a68f80de9c376
+
+pkgname = libbuspirate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5266ad8d1d7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+pkgname=libbuspirate
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="The libbuspirate is a C library to talk with the bus pirate hardware"
+arch=("i686" "x86_64" "armv6h") # maybe more ?
+url="http://sourceforge.net/projects/libbuspirate/"
+license=('GPLv3')
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
+sha1sums=('fbbfdddec5ef46870463d654bb2a68f80de9c376')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}