summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Nelless2015-08-23 00:25:19 +0100
committerAndrew Nelless2015-08-23 00:25:19 +0100
commitecf69e1d1822f4c569815088f21c28e104b274ca (patch)
tree69f9a96296a5be5beae87df142de57dedacfe83d
parent20e54846998affdede814f65229dfdfea0fd1913 (diff)
downloadaur-ecf69e1d1822f4c569815088f21c28e104b274ca.tar.gz
Update to 3.6.2
-rw-r--r--PKGBUILD6
-rw-r--r--libc++-msan.install3
2 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a6d4d471130..b76d1c01995c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Daniel Micay <danielmicay@gmail.com>
# Contributor: MThinkCpp <mtc.maintainer[at]outlook.com>
pkgname=libc++-msan
-pkgver=3.6.0
+pkgver=3.6.2
pkgrel=1
pkgdesc='Standard C++ library implementation from the LLVM project (Memory Sanitizer enabled)'
url='http://libcxx.llvm.org'
@@ -11,11 +11,11 @@ license=('custom:University of Illinois/NCSA Open Source License')
arch=('i686' 'x86_64')
# gcc-libs needed for libgcc_s, because Arch doesn't use a pure compiler-rt clang
depends=('glibc' 'libc++abi' 'gcc-libs')
-makedepends=('clang' 'subversion' 'cmake')
+makedepends=('clang' 'cmake')
provides=('libc++')
conflicts=('libc++')
source=("http://www.llvm.org/releases/$pkgver/libcxx-${pkgver}.src.tar.xz")
-md5sums=('5d4a2ff4e2023eaa3f2025e26274d504')
+md5sums=('22214c90697636ef960a49aef7c1823a')
options=('debug' '!strip')
install=${pkgname}.install
diff --git a/libc++-msan.install b/libc++-msan.install
index caef683ae99a..608ace2114ec 100644
--- a/libc++-msan.install
+++ b/libc++-msan.install
@@ -1,5 +1,6 @@
post_install() {
- echo compile with \`clang++ -std=c++11 -stdlib=libc++ -lc++abi\` to use libc++
+ echo compile with \`clang++ -std=c++11 -stdlib=libc++ -fsanitize=memory -lc++abi\` to use libc++-msan
+ echo "see http://clang.llvm.org/docs/MemorySanitizer.html for further instructions"
}
post_upgrade() {