summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamLukeYes2021-05-26 21:40:22 +0800
committerSamLukeYes2021-05-26 21:40:22 +0800
commitc6afd041678577769e73003c08cccf4617e91322 (patch)
treeabefbc13fd22d6d04b769990f551fb53930235e8
parent0e44b44516ffcbe47018583578b931f3a3a1d80f (diff)
downloadaur-c6afd041678577769e73003c08cccf4617e91322.tar.gz
disable raspberrypi IPA module
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff0e6aac3ea7..fc502d20de40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libcamera-clang-git
pkgdesc = A complex camera support library for Linux, Android, and ChromeOS (built with clang)
- pkgver = r2570.0906ddb2
+ pkgver = r2623.258c7481
pkgrel = 1
url = https://libcamera.org/
arch = x86_64
@@ -36,4 +36,3 @@ pkgbase = libcamera-clang-git
md5sums = SKIP
pkgname = libcamera-clang-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e293c193be08..946a42274185 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sam L. Yes <samlukeyes123@gmail.com>
pkgname=libcamera-clang-git
-pkgver=r2570.0906ddb2
+pkgver=r2623.258c7481
pkgrel=1
pkgdesc='A complex camera support library for Linux, Android, and ChromeOS (built with clang)'
arch=('x86_64' 'i686')
@@ -43,6 +43,7 @@ build() {
CC=clang CXX=clang++ arch-meson build \
-Dwerror=false \
-Dv4l2=true \
+ -Dipas=ipu3,rkisp1,vimc \
-Dpipelines=ipu3,rkisp1,simple,uvcvideo,vimc \
-Ddocumentation=disabled \
-Dtracing=disabled # comment this line to enable LTTng support
@@ -50,8 +51,6 @@ build() {
ninja -C build
}
-# If this check fails, use --nocheck to skip it
-
check() {
cd ${srcdir}/libcamera
meson test -C build