summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGennadiy Mykhailiuta2021-03-21 23:35:25 +0000
committerGennadiy Mykhailiuta2021-03-21 23:35:25 +0000
commit585a6bf3af9a5750f63abf0401034634acb55b62 (patch)
tree5c398216619512c1e13a0e62d2dfd1952985284f
parent74c2a3672c544f5c66b5d8b99e1e58f154be4638 (diff)
downloadaur-585a6bf3af9a5750f63abf0401034634acb55b62.tar.gz
Switch to arch-meson
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6be807a2419..02c99ac85f91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,6 +13,7 @@ pkgbase = libcamera-git
makedepends = python-yaml
makedepends = python-ply
makedepends = python-jinja
+ makedepends = lttng-ust
optdepends = boost
optdepends = udev
optdepends = python-sphinx
diff --git a/PKGBUILD b/PKGBUILD
index 29dda0585727..33378afeab0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,7 @@ makedepends=(
"python-yaml"
"python-ply"
"python-jinja"
+ "lttng-ust"
)
optdepends=(
"boost"
@@ -37,7 +38,10 @@ pkgver() {
build() {
cd "${srcdir}/libcamera"
- meson build --prefix /usr -Dwerror=false
+ arch-meson build \
+ -D werror=false \
+ -D documentation=disabled \
+ -D tracing=disabled
ninja -C build
}