summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoel2015-06-17 23:38:00 +0200
committerjoel2015-06-17 23:38:00 +0200
commit321eb5db1c7818359b2915d9d5cbb21d6ffa73ee (patch)
tree82fe161f28bc9ea144d328d0babf68f6e6a3bbff
downloadaur-321eb5db1c7818359b2915d9d5cbb21d6ffa73ee.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..345223f1973c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libcatch-cpp-headers
+ pkgdesc = C++-native framework for unit-tests using only a header file
+ pkgver = 1.1build3
+ pkgrel = 1
+ url = http://catch-lib.net
+ arch = any
+ license = custom:BSL
+ source = https://raw.github.com/philsquared/Catch/master/single_include/catch.hpp
+ source = LICENSE::https://raw.githubusercontent.com/philsquared/Catch/master/LICENSE_1_0.txt
+ sha256sums = 0de165d0fef3ff5dbf45feb1c6c92b8421a05c6268dc2d4f8fdf58fb615cbdfa
+ sha256sums = c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566
+
+pkgname = libcatch-cpp-headers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5d07fc9fcbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: yozi <es.mslj TA xunilhcra> backwards
+# Contributor: Bernd Amend <bernd.amend+extension_system gmail com>
+pkgname='libcatch-cpp-headers'
+pkgver=1.1build3
+pkgrel=1
+pkgdesc='C++-native framework for unit-tests using only a header file'
+arch=(any)
+url='http://catch-lib.net'
+license=('custom:BSL')
+source=('https://raw.github.com/philsquared/Catch/master/single_include/catch.hpp'
+ 'LICENSE::https://raw.githubusercontent.com/philsquared/Catch/master/LICENSE_1_0.txt')
+sha256sums=('0de165d0fef3ff5dbf45feb1c6c92b8421a05c6268dc2d4f8fdf58fb615cbdfa'
+ 'c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566')
+
+pkgver() {
+ echo $(grep -oEm1 \
+ "^*.*CATCH v([0-9])(\.[0-9]+)+ build ([0-9]+)" \
+ catch.hpp | cut -d'v' -f2 | tr -d ' ')
+}
+
+package() {
+ install -D -m644 catch.hpp "${pkgdir}/usr/include/catch.hpp"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: