summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Klimeš2020-08-06 21:49:46 +0200
committerJiří Klimeš2020-08-06 21:49:46 +0200
commit1eeb0d50e4cfd61bd0a244628896999d25863288 (patch)
treefa38406af978bb27f72b77135473dcd7b77f6517
parent963dd42eb064aa95af943c52e0ebfcc19c6d7b1b (diff)
downloadaur-1eeb0d50e4cfd61bd0a244628896999d25863288.tar.gz
Lua 5.4 is now default in Arch Linux - update for that
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27d12f5b354..3388075319a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,9 +12,11 @@ pkgbase = libcd
makedepends = lua
makedepends = lua51
makedepends = lua52
+ makedepends = lua53
makedepends = lua-im
makedepends = lua51-im
makedepends = lua52-im
+ makedepends = lua53-im
source = https://downloads.sourceforge.net/project/canvasdraw/5.14/Docs%20and%20Sources/cd-5.14_Sources.tar.gz
source = https://downloads.sourceforge.net/project/canvasdraw/5.14/Docs%20and%20Sources/ftgl-2.1.5_Sources.tar.gz
source = https://downloads.sourceforge.net/project/canvasdraw/5.14/Docs%20and%20Sources/cd-5.14_Docs.pdf
@@ -30,7 +32,7 @@ pkgname = libcd
depends = gtk3
pkgname = lua-cd
- pkgdesc = Lua (5.3) bindings for Canvas Draw library
+ pkgdesc = Lua (5.4) bindings for Canvas Draw library
depends = libcd
pkgname = lua51-cd
@@ -41,3 +43,7 @@ pkgname = lua52-cd
pkgdesc = Lua (5.2) bindings for Canvas Draw library
depends = libcd
+pkgname = lua53-cd
+ pkgdesc = Lua (5.3) bindings for Canvas Draw library
+ depends = libcd
+
diff --git a/PKGBUILD b/PKGBUILD
index e573a616605..7529a37d17d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Karro <karolina.lindqvist@kramnet.se>
pkgbase=libcd
-pkgname=('libcd' 'lua-cd' 'lua51-cd' 'lua52-cd')
+pkgname=('libcd' 'lua-cd' 'lua51-cd' 'lua52-cd' 'lua53-cd')
pkgdesc="Canvas Draw - 2D vector graphics library"
pkgver=5.14
pkgrel=1
arch=('i686' 'x86_64')
url="https://www.tecgraf.puc-rio.br/cd/"
-makedepends=('glu' 'pdflib-lite' 'lsb-release' 'lua' 'lua51' 'lua52' 'lua-im' 'lua51-im' 'lua52-im')
+makedepends=('glu' 'pdflib-lite' 'lsb-release' 'lua' 'lua51' 'lua52' 'lua53' 'lua-im' 'lua51-im' 'lua52-im' 'lua53-im')
license=('MIT')
_ftglver=2.1.5
source=(
@@ -44,12 +44,21 @@ build() {
USE_FTGL=Yes \
USE_GTK3=Yes
+ echo 'Building Lua 5.4 bindings'
+ make cdlua5 cdluapdf5 cdluagl5 cdluacontextplus5 cdluaim5 \
+ STDLDFLAGS="-shared -Wl,-rpath=/usr/lib/lua/5.4,--enable-new-dtags,--as-needed" \
+ IM_INC=/usr/include/im \
+ IM_LIB=/usr/lib \
+ IMLUA_LIB=/usr/lib/lua/5.4 \
+ USE_LUA54=Yes
+
echo 'Building Lua 5.3 bindings'
make cdlua5 cdluapdf5 cdluagl5 cdluacontextplus5 cdluaim5 \
STDLDFLAGS="-shared -Wl,-rpath=/usr/lib/lua/5.3,--enable-new-dtags,--as-needed" \
IM_INC=/usr/include/im \
IM_LIB=/usr/lib \
IMLUA_LIB=/usr/lib/lua/5.3 \
+ LUA_INC=/usr/include/lua5.3 \
USE_LUA53=Yes
echo 'Building Lua 5.2 bindings'
@@ -87,7 +96,7 @@ package_libcd() {
}
_lua_cd_package_helper() {
- # $1 ... Lua version ("5.1", "5.2" or "5.3")
+ # $1 ... Lua version ("5.1", "5.2", "5.3" or "5.4")
_lua_ver=$1
_lua_ver_nodot=`echo $1 | cut -c1,3`
@@ -110,6 +119,13 @@ _lua_cd_package_helper() {
}
package_lua-cd() {
+ pkgdesc="Lua (5.4) bindings for Canvas Draw library"
+ depends=('libcd')
+
+ _lua_cd_package_helper "5.4"
+}
+
+package_lua53-cd() {
pkgdesc="Lua (5.3) bindings for Canvas Draw library"
depends=('libcd')