summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-01-24 12:37:07 -0600
committerLuis Martinez2023-01-24 12:37:07 -0600
commite00a7aa5fb714625038dd846d77ab80d258d0ed7 (patch)
tree910d5777d8f509f54696f6cd7d4fa82b4219bc82
parent7f8f0233f346f102671042380d3f78f18ea36add (diff)
downloadaur-e00a7aa5fb714625038dd846d77ab80d258d0ed7.tar.gz
packaging cleanup
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD50
2 files changed, 30 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72bf4eaba663..15af00dc4db8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,16 @@
pkgbase = libcerror-git
pkgdesc = Library for cross-platform C error functions
- pkgver = 20180515.56224d9
+ pkgver = 20220101.r9.ga8e7608
pkgrel = 1
url = https://github.com/libyal/libcerror
- arch = any
- license = LGPL
+ arch = x86_64
+ license = LGPL3
+ license = GPL3
makedepends = git
- makedepends = autoconf
- makedepends = automake
- makedepends = libtool
- makedepends = gettext
- makedepends = pkg-config
- makedepends = bison
- makedepends = flex
- provides = libcerror-git
+ depends = glibc
+ provides = libcerror
conflicts = libcerror
- source = git+https://github.com/libyal/libcerror.git
- sha1sums = SKIP
+ source = libcerror::git+https://github.com/libyal/libcerror
+ sha256sums = SKIP
pkgname = libcerror-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 53bef5b02823..a8ca5fb242cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,36 @@
-# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
pkgname=libcerror-git
-pkgver=20180515.56224d9
+_pkg="${pkgname%-git}"
+pkgver=20220101.r9.ga8e7608
pkgrel=1
pkgdesc='Library for cross-platform C error functions'
-arch=('any')
+arch=('x86_64')
url='https://github.com/libyal/libcerror'
-license=('LGPL')
-provides=('libcerror-git')
-conflicts=('libcerror')
-groups=()
-depends=()
-makedepends=('git' 'autoconf' 'automake' 'libtool' 'gettext' 'pkg-config' 'bison' 'flex')
-optdepends=()
-options=()
-source=('git+https://github.com/libyal/libcerror.git')
-sha1sums=('SKIP')
-
-_gitname="libcerror"
+license=('LGPL3' 'GPL3')
+provides=("$_pkg")
+conflicts=("$_pkg")
+depends=('glibc')
+makedepends=('git')
+source=("$_pkg::git+$url")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_gitname"
- git log -1 --format='%cd.%h' --date=short | tr -d -
+ git -C "$_pkg" describe --long --tags | sed 's/-/.r/;s/-/./'
}
build() {
- cd "$_gitname"
-
- ./synclibs.sh
- ./autogen.sh
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc
-
- make
+ cd "$_pkg"
+ ./synclibs.sh
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ make
}
package() {
- cd "$_gitname"
- make DESTDIR="$pkgdir/" install
+ cd "$_pkg"
+ make DESTDIR="$pkgdir/" install
}