summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Panteleev2016-11-13 14:20:48 +0000
committerVladimir Panteleev2016-11-13 14:20:48 +0000
commit954d1f176a04e31abc85b10d954559eef7848fbf (patch)
tree4efffcf80e91e7b8bae5bd2c7895cd7f7c8e9540
downloadaur-954d1f176a04e31abc85b10d954559eef7848fbf.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..892d6da2d626
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Nov 13 14:19:47 UTC 2016
+pkgbase = libcfg+
+ pkgdesc = command line and configuration file parsing library
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = http://opensource.platon.org/projects/main_page.php?project_id=3
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://opensource.platon.org/upload/_projects/00003/libcfg+-0.7.0.tar.gz
+ md5sums = 7f8a415e508da4b2b060d3894d4c510a
+
+pkgname = libcfg+
+
+pkgname = libcfg+-docs
+ pkgdesc = command line and configuration file parsing library (documentation)
+ arch = any
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3b8ec2afcbca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..316eecc38814
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Vladimir Panteleev <arch-pkg at thecybershadow.net>
+pkgbase=libcfg+
+pkgname=(libcfg+ libcfg+-docs)
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="command line and configuration file parsing library"
+arch=('i686' 'x86_64')
+url="http://opensource.platon.org/projects/main_page.php?project_id=3"
+license=('GPL')
+depends=()
+source=("http://opensource.platon.org/upload/_projects/00003/libcfg+-${pkgver}.tar.gz")
+md5sums=('7f8a415e508da4b2b060d3894d4c510a')
+
+build() {
+ cd "$srcdir/$pkgbase-$pkgver"
+
+ unset CFLAGS LDFLAGS
+
+ ./configure --prefix=/usr
+ make
+}
+
+package_libcfg+() {
+ cd "$srcdir/$pkgbase-$pkgver"
+
+ make -j1 DESTDIR="$pkgdir/" install
+ rm -rf "$pkgdir/usr/share"
+}
+
+package_libcfg+-docs() {
+ pkgdesc="${pkgdesc} (documentation)"
+ arch=(any)
+
+ cd "$srcdir/$pkgbase-$pkgver"
+
+ make -j1 DESTDIR="$pkgdir/" install
+ rm -rf "$pkgdir/usr/include" "$pkgdir/usr/lib"
+}