summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2019-03-16 20:07:01 +0800
committerChih-Hsuan Yen2019-03-16 20:07:01 +0800
commit06ca702b696bea11d54600ee428210e1e2b11c48 (patch)
tree6333a40e9834bd9afcb3bbf6a440e58f557098f7
parent83f9862c7ba52bbca6c7b0fc8d7cc946fa8c0e52 (diff)
downloadaur-06ca702b696bea11d54600ee428210e1e2b11c48.tar.gz
update and misc. improvements
* Switch to CMake. There are some bugs in the autotools-based build system [1][2] and seems the CMake-based one is just fine. * Drop a landed patch, which is for the autotools-based build system, though. * Use the correct license. [1] https://github.com/chewing/libchewing/pull/295#issuecomment-473519265 [2] https://github.com/yan12125/libchewing/tree/fix-autogen-warnings
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD34
3 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f8643d653c8..8056bdece32b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = libchewing-git
pkgdesc = Intelligent Chinese phonetic input method
- pkgver = 0.5.1.r74.g3df07c9
+ pkgver = 0.5.1.r95.gb082732
pkgrel = 1
epoch = 1
url = http://chewing.im/
arch = i686
arch = x86_64
- license = GPL
+ license = LGPL2.1
+ makedepends = cmake
makedepends = git
depends = sqlite
- provides = libchewing=0.5.1.r74.g3df07c9
+ provides = libchewing=0.5.1.r95.gb082732
conflicts = libchewing
source = git+https://github.com/chewing/libchewing/
- source = issue219.patch::https://github.com/chewing/libchewing/pull/294.patch
md5sums = SKIP
- md5sums = 22a1d758203218c3f1e264eac77017e5
pkgname = libchewing-git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 7576c0117a25..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-/libchewing/
diff --git a/PKGBUILD b/PKGBUILD
index cb84597524d4..b14462ff330a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,50 +3,48 @@
_pkgname=libchewing
pkgname=libchewing-git
-pkgver=0.5.1.r74.g3df07c9
+pkgver=0.5.1.r95.gb082732
pkgrel=1
epoch=1
pkgdesc='Intelligent Chinese phonetic input method'
url='http://chewing.im/'
arch=('i686' 'x86_64')
-license=('GPL')
+license=('LGPL2.1')
conflicts=("$_pkgname")
provides=("$_pkgname=$pkgver")
depends=('sqlite')
-makedepends=('git')
-source=("git+https://github.com/chewing/libchewing/"
- "issue219.patch"::"https://github.com/chewing/libchewing/pull/294.patch")
-md5sums=('SKIP'
- '22a1d758203218c3f1e264eac77017e5')
+makedepends=('cmake' 'git')
+source=("git+https://github.com/chewing/libchewing/")
+md5sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd "$_pkgname"
( set -o pipefail
git describe --long --tag 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
)
}
prepare() {
- cd "${_pkgname}"
-
- patch -Np1 -i ../issue219.patch
-
- autoreconf -fvi
+ cd "$_pkgname"
+ mkdir build
}
build() {
- cd "${_pkgname}"
- ./configure --prefix=/usr --disable-static
+ cd $_pkgname/build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ ..
make
}
check() {
- cd "${_pkgname}"
+ cd $_pkgname/build
# parallel testing is broken (https://github.com/chewing/libchewing/issues/293)
make -j1 check
}
package() {
- cd "${_pkgname}"
- make DESTDIR="${pkgdir}" install
+ cd $_pkgname/build
+ make DESTDIR="$pkgdir" install
}