summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2023-02-02 18:40:25 +0800
committerChih-Hsuan Yen2023-02-02 18:40:25 +0800
commit62035b04706376ad432a24303ba658974aeada7d (patch)
tree61576a58edb4e9418fc07f95522a2537075b2d27
parent2307d9940464e9a305d69311fc6d71d15ee01676 (diff)
downloadaur-62035b04706376ad432a24303ba658974aeada7d.tar.gz
libchewing-git: upstream ABI is compatible again
Inadvertent ABI changes are fixed [1], so PKGBUILD changes in [2] are reverted. Other minor changes: * https://chewing.im is now available * debug is now enabled by default * Bring back the info page, which is disabled by default along with the Rust rewrite [3] * archlinuxcn-specific: * Merge lilac.py into lilac.yaml * Manage the AUR repo by myself instead of delegating it to lilac * Move away from vcs nvchecker source [1] https://github.com/chewing/libchewing/pull/372 [2] https://github.com/archlinuxcn/repo/commit/27463c4e7562a50e757b6f2fe8d8223be44e9c96 [3] https://github.com/chewing/libchewing/commit/9739747f7e2d1bee8fd2225095ec375bc83073b9
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6647c48cbd34..ec67666f8c35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = libchewing-git
pkgdesc = Intelligent Chinese phonetic input method
- pkgver = 0.5.1.r109.g89ef2a8
- pkgrel = 2
+ pkgver = 0.5.1.r159.gfad98d6
+ pkgrel = 1
epoch = 1
- url = http://chewing.im/
+ url = https://chewing.im/
arch = i686
arch = x86_64
license = LGPL2.1
makedepends = cmake
makedepends = git
depends = sqlite
+ provides = libchewing
conflicts = libchewing
- options = debug
source = git+https://github.com/chewing/libchewing/
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f772671b7775..5c785a7e17d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
_pkgname=libchewing
pkgname=libchewing-git
-pkgver=0.5.1.r109.g89ef2a8
-pkgrel=2
+pkgver=0.5.1.r159.gfad98d6
+pkgrel=1
epoch=1
pkgdesc='Intelligent Chinese phonetic input method'
-url='http://chewing.im/'
+url='https://chewing.im/'
arch=('i686' 'x86_64')
license=('LGPL2.1')
conflicts=("$_pkgname")
+provides=("$_pkgname")
depends=('sqlite')
makedepends=('cmake' 'git')
source=("git+https://github.com/chewing/libchewing/")
md5sums=('SKIP')
-options=('debug')
pkgver() {
cd "$_pkgname"
@@ -34,6 +34,7 @@ build() {
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DBUILD_INFO=ON \
..
make
}