summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-08-25 17:56:27 +0800
committerChih-Hsuan Yen2018-08-25 17:56:27 +0800
commit83f9862c7ba52bbca6c7b0fc8d7cc946fa8c0e52 (patch)
tree434d9b8e02b26810cbd60e25d3fbf65c2e1152d2
parent115e58f3dd9b92a86ecab7377973fe7aba4da906 (diff)
downloadaur-83f9862c7ba52bbca6c7b0fc8d7cc946fa8c0e52.tar.gz
submit patches to upstream
And misc changes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--issue219.patch12
3 files changed, 11 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a83f39a400d..8f8643d653c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,12 +9,12 @@ pkgbase = libchewing-git
license = GPL
makedepends = git
depends = sqlite
- provides = libchewing
+ provides = libchewing=0.5.1.r74.g3df07c9
conflicts = libchewing
source = git+https://github.com/chewing/libchewing/
- source = issue219.patch
+ source = issue219.patch::https://github.com/chewing/libchewing/pull/294.patch
md5sums = SKIP
- md5sums = 16f494709a35233177ba6bc234953871
+ md5sums = 22a1d758203218c3f1e264eac77017e5
pkgname = libchewing-git
diff --git a/PKGBUILD b/PKGBUILD
index 623d00e859e0..cb84597524d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,20 +10,19 @@ pkgdesc='Intelligent Chinese phonetic input method'
url='http://chewing.im/'
arch=('i686' 'x86_64')
license=('GPL')
-conflicts=('libchewing')
-provides=('libchewing')
+conflicts=("$_pkgname")
+provides=("$_pkgname=$pkgver")
depends=('sqlite')
makedepends=('git')
source=("git+https://github.com/chewing/libchewing/"
- "issue219.patch")
+ "issue219.patch"::"https://github.com/chewing/libchewing/pull/294.patch")
md5sums=('SKIP'
- '16f494709a35233177ba6bc234953871')
+ '22a1d758203218c3f1e264eac77017e5')
pkgver() {
cd "${_pkgname}"
( set -o pipefail
- git describe --long --tag 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tag 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
)
}
@@ -31,18 +30,19 @@ prepare() {
cd "${_pkgname}"
patch -Np1 -i ../issue219.patch
+
+ autoreconf -fvi
}
build() {
cd "${_pkgname}"
- ./autogen.sh
./configure --prefix=/usr --disable-static
make
}
check() {
cd "${_pkgname}"
- # parallel testing is broken
+ # parallel testing is broken (https://github.com/chewing/libchewing/issues/293)
make -j1 check
}
diff --git a/issue219.patch b/issue219.patch
deleted file mode 100644
index 8a912d6dcf63..000000000000
--- a/issue219.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/test/Makefile.am b/test/Makefile.am
-index 3df720b..09b3c29 100644
---- a/test/Makefile.am
-+++ b/test/Makefile.am
-@@ -87,6 +87,7 @@ LDADD = \
- $(top_builddir)/src/common/libcommon.la \
- $(top_builddir)/src/porting_layer/src/libporting_layer.la \
- $(top_builddir)/test/libtesthelper.la \
-+ $(top_builddir)/src/common/libcommon.la \
- $(NULL)
-
- AM_LDFLAGS = -static