summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2015-08-30 00:39:53 +0800
committerYen Chi Hsuan2015-08-30 00:39:53 +0800
commit8bf1cd90bd13846cb91d46abf39c73233213deff (patch)
treefc54a7ac1dd62e08475c05f6e00c024761aa2f85
downloadaur-8bf1cd90bd13846cb91d46abf39c73233213deff.tar.gz
Import and bump
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD31
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09735207e2d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libchewing-git
+ pkgdesc = Intelligent Chinese phonetic input method
+ pkgver = 1567.ba4c90b
+ pkgrel = 1
+ url = http://chewing.im/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ provides = libchewing
+ conflicts = libchewing
+ source = git://github.com/chewing/libchewing/
+ md5sums = SKIP
+
+pkgname = libchewing-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7576c0117a25
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/libchewing/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83af3e3628e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yushin Huang <hyslion AT gmail.com>
+
+_pkgname=libchewing
+pkgname=libchewing-git
+pkgver=1567.ba4c90b
+pkgrel=1
+pkgdesc='Intelligent Chinese phonetic input method'
+url='http://chewing.im/'
+arch=('i686' 'x86_64')
+license=('GPL')
+conflicts=('libchewing')
+provides=('libchewing')
+source=("git://github.com/chewing/libchewing/")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${_pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}