summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2024-03-12 11:45:14 +0800
committerChih-Hsuan Yen2024-03-12 11:45:14 +0800
commit8e6b7e4be01a5556981b56390e6f15654b633ea5 (patch)
tree9c9bdcd813891f11e41bc2c3de365468e224a0e4
parent7e509c539ef05df4c5c0950ef181d87b561a540e (diff)
downloadaur-8e6b7e4be01a5556981b56390e6f15654b633ea5.tar.gz
libchewing-git: fix building
In https://github.com/chewing/libchewing/pull/447, upstream drops custom FindCurses.cmake in favor of the one provided by CMake. Somehow that broke header detection on Arch Linux.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b81100489d0..07287f26e6f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libchewing-git
pkgdesc = Intelligent Chinese phonetic input method
- pkgver = 0.6.0rc.1.r0.g06b577b
+ pkgver = 0.6.0.r37.gcafe3a2
pkgrel = 1
epoch = 1
url = https://chewing.im/
diff --git a/PKGBUILD b/PKGBUILD
index bed32df3eadd..58190861cd2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=libchewing
pkgname=libchewing-git
-pkgver=0.6.0rc.1.r0.g06b577b
+pkgver=0.6.0.r37.gcafe3a2
pkgrel=1
epoch=1
pkgdesc='Intelligent Chinese phonetic input method'
@@ -31,10 +31,12 @@ prepare() {
build() {
cd $_pkgname/build
+ # Specify the existence of ncurses.h manually as FindCurses.cmake cannot identify it
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DBUILD_INFO=ON \
+ -DCURSES_HAVE_NCURSES_H=ON \
..
make
}